Jump to content

My new toy!


HabMP
 Share

Recommended Posts

If I have posted this in the wrong section, apologies now!

Just bought this 2 weeks ago, and loving it in the snow.

Bought it because we moved house, and I knew we would need a 4x4 to get up and down.

I also have a 6 year old BMW Coupe, and a 12 year old Z3, so a bit of a car freak.

Only 2 small problems so far, which as far as people tell me is a miracle!

1) Passenger elec front window doesn't work.

2) NS headlamp seems to have some sort of fault. It keeps showing as just sidelight, but I have changed the headlamp bulbs.

Apart from that, it is perfect. I know that other stuff will go wrong, but I'll deal with that when it arrives.

Changed the leather gaiters, with a £10 set from EBAY, perfect fit. I am guessing to change the handbrake one, that I have to take out the cubby box?

Can't believe I left it so long before I bought into this....

Any help on the above appreciated.

Cheers

Mike

post-27703-059039800 1291146901_thumb.jpg

post-27703-017294700 1291146909_thumb.jpg

post-27703-062787800 1291146916_thumb.jpg

post-27703-010077100 1291146925_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy