Jump to content

Whats this noise?


Igol
 Share

Recommended Posts

Now what?

I’ve just gone out on a test drive after replacing my front wheel bearing on my 97 Disco. Front end seems fine but as I set off there was a horrible noise a selection of grinding and squeaking from the back end of the car. ABS light is also stuck on, I had assumed that this was to do with the front bearing as it came on when that went.

Jacked her up and rear bearings are both fine no play at all. I’ve jumped up and down on the tow hook and suspension seems fine and the noise doesn’t get any worse when you go over pot holes/speed bumps.

I’m now thinking something to do with the brake callipers and checked to see if the pads have dropped through the calliper but there’s no scoring on the hub any other suggestions more than welcome.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy