Jump to content

power


5432erick
 Share

Recommended Posts

hi all i posted awhile back about loss of power every mile i had electronics checked no fault i then had filter cleaned and new breather pipe told to drill hole in petrol cap even ran without cap but problem still there do u think i should have new pump as its mind boggling and the garage doesnt seem to know its been in three times costa mega buks need all help i can get thanks

Link to comment
Share on other sites

Can you remind us what the vehicle is - petrol, diesel?

I had a dicky pump on my 1.8 but it was the pins in the fuel pump connector, I used a pair of needle nose pliers to put a slight twist in them and they made better contact and it was all sorted. I've got a spare pump in my shed I need to shift actually ;)

Link to comment
Share on other sites

My freelander 1.8 has experienced similar issues - I have difficult staring sometimes and lack of power - if it's a '99 or before problem it could be the filter in the rear fuel pump needs replacing - there is a land rover bulletin for it. See the think in this thread: http://forums.lr4x4.com/index.php?showtopic=49047&st=0&p=445354&hl=+freelander%20+fuel%20+filter&fromsearch=1entry445354

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy