Jump to content

Electrical help,


madmatt
 Share

Recommended Posts

Afternoon all,

My friend has an 03 TD4 Freelander, She had some Day time running lights added a couple of years ago and today asked me to take a look as to why they are not working. whoever fitted them has taken the positive feed from inside the fuse/relay box in the engine compartment. They have used a spare relay holder as pictured below.

freelander001.jpg

freelander005.jpg

I have tested the terminal with a meter and there is no feed with or without the ignition on, I think the fuse has gone as the lights have worked fine for many months the problem is niether of us know where to find the fuse for this relay holder

Can anyone help?

Many Thanks

Matt

Link to comment
Share on other sites

It'll be in the RAVE manuals, free download in the tech archive.

As far as I'm aware the FL only has two places for fuses, there and in the fusebox under the steering wheel (mentioned & pictured in the owner's manual) so I'd start there and look for what's blown.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy