Jump to content

Freelander 1.8 not starting - immobiliser?


emeye
 Share

Recommended Posts

Just got my 1999 1.8 Freelander back after having the rear fuel filter and some water pipes replaced it ran fine for a few days, but last night it wouldn't start.

All the dash lights came on and there was a click as I turned the key but nothing else. The car locked and unlocked with out any problems. Lights came on with no prob.

I checked the fuses etc and then I disconnected and reconnected the huge multi-connector that goes into the side of the silver box under the bonnet (guessing this is the ECU?) and it then started and I got home OK.

Unfortunately this morning I had exactly the same problem, but unplugging/replugging the connector made no difference - I've tried the other key/keyfob but still the same problem.

So, could a wire or earth strap have come loose? Could it be the immobiliser?

Help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy