Jump to content

Recommended Posts

I have a 2002 td5 defender 90. When you reach between 65/70 mph it feels as though the engine has limiter the turbo seems to stop working.If you stop and start again the engine is fine and the turbo is working. Any ideas it has just had a new genuine rr airflow metre fitted .

Link to post
Share on other sites

Sounds to me like the turbo boost had been adjusted too far, the pressure is monitored by the ECU and if it goes over the limit (1 bar?) the ECU goes into "limp" mode until it's shut down and re-started.

Link to post
Share on other sites

Also check red plug on ECU for oil, had one doing the same it was oil in the loom. The wastgate in the manifold can seize up. Under the heat shield there's a rod and on one end there's the wastgate actuator, the other end is the wastgate (just a lever going into the manifold) you need to make sure this is free to move it will be hard to move but it should.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy