Jump to content

central locking


Recommended Posts


the central locking on my disco didn't work, not at all. After checking the connectors with a multimeter I reckoned the actuators were dead (all of them!) and had probably been this way for a while. gave up and used the key and inside buttons.

rummaging through maplin the other day I spotted a cheap kit with 4 door actuators for £21. couldn't resist, so I bought it and studied the wiring diagrams for the disco and the kit. They were different but had some things in common. So I worked out how the fit the two together.

Today I removed the disco actuators and replaced them with the maplin ones, spliced the maplin units into the disco loom but used the maplin control box. 2 hours later and I have central locking.

The disco also has a basic remote alarm with an output to operate the central locking. trouble is at the moment the alarm lock trigger goes low when locked and high when unlocked. the maplin unit has two wires which go low in turn to lock and unlock. now I need to figure out a little black box that takes on low signal trigger and alternates in to two low outputs, reliably!

when this works I'll have remote central locking just as god intended with no messing with springs or dodgy actuators.




Link to comment
Share on other sites

Good post Gary. Still trying to track down the fault with mine (5dr 200Tdi).

After replacing the fuse the drivers door now also actuates the rear door but all passenger doors refuse to do anything. Been round them all to lub and seem free enough. Just seemed odd that three could pack up at the same time but seems form your post it does happen.

If I understand the workings the OSF master actuator provides a short 12v supply to the other actuators (and reverses the polarity on unlock). Testing the OSR door voltage is getting through but haven't yet tested the actuator wired direct to the battery. Actuator seems free enough.

Also unsure why the fuse had blown.

Link to comment
Share on other sites

trev, still working although the actuators have needed to be fine tuned. I guess your motors may have siezed and blown the fuse through too much current.

all of my original actuators were free and moved in and out manually but none would move at all when energised. stripped them and tried to power just the motor from direct 12v, still nothing. the maplin kit provided the solution I needed and was cheap too.


Link to comment
Share on other sites

Yes, mine move easily but haven't tested them with a 12v supply yet (hadn't got my head that far round it when all the door cards were off). Got a few other more pressing things to fix at the mo but will get back to this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy