Jump to content

Strange brake bleeding problem - help required


M&S
 Share

Recommended Posts

Hi all, not technically Land Rover but a brake problem that could easily be and I trust you guys more than the rest of the web!

I could really do with some help with...

I'm trying to bleed my brakes as the pedal went quite soft. It gradually got softer. I pumped the pedal, it came hard, left it, next day still hard until I used the brakes. Now it is just soft all teh way to the floor and won't build up any pressure.

I first thought master cylinder, but thought I'd try bleeding first. Put my pressure bleeder on as I have done for 15 years, and opened the bleed nipple. Nothing, nowt, nadda. Tried another caliper, same, nothing.

Pressure bleeder is working as it's filled the reservoir, and I've upped the pressure, still nothing.

Asking a friend to press the pedal and do it the old fashioned way isn't working either. I get the tiniest amount of fluid out, I mean a barely noticeable dribble, for each press of the pedal. Not enough to make it through a pipe. I mean it really is teh smallest amount.

Any ideas? I've had problems before but managed to work them out, this time I am stumped.

No leaks anywhere. If I had a faulty master cylinder surely I'd still get fluid through with the pressure bleeder, always have done before. Tried pressure bleeding with pedal up, mid-way and down and still nowt.

Even tried with the engine running incase teh ABS module was blocking something, but that's made no difference. Even considered gravity bleeding but if the pressure kit isn't pushing anything through I doubt gravity would!

Very confused and frustrated. Have NO brake pressure at all so can't even take the vehicle to a garage (wouldn't want to either!).

Any tips?

Link to comment
Share on other sites

Hi guys.

Tried pumping with the pressure bleeder attached, still nothing. Just come in because I am soaked, freezing and out of ideas still.

But..I have undone the pipes on the output of the ABS module and pumped the pedal, and fluid gushed out so that's good I guess.

If fluid is getting to, and through, the ABS module that would suggest blocked brake line, but all of them, and only after the ABS, seems highly unlikely.

Removed thebleed nipples as well to check it wasn't those that were blocked. Need a new caliper now as someone had heli-coiled one of them in and made a right hash of it!

I have been left thinking that the reservoir to master cylinder could be blocked, but tehre are two supply ports to the master cylinder. Again, chance of both been blocked seems remote and the fluid is new/clean as the servo and a brake pipe was replaced for teh MOT two months ago.

Eliminated the rear bias valve (if it has one) as I'm getting nothing at the front.

With the bleed nipple left out of the rear caliper for an hour, and having the pressure bleed on nothing has come out.

So questions:

If the master cylinder was faulty, would the pressure bleed not work? I'd expect fluid to come through regardless

If the master cyclinder was faulty then how come I'm getting fluid to and from the ABS module when pressing the pedal?

If both inlet ports on the master cylinder were blocked, again, how come I'm getting fluid at the output of the ABS module.

And finally, why is no brake fluid coming out at the calipers :unsure:

This is driving me nuts. Doesn't help it's cold, dark, and very wet but even so!

Link to comment
Share on other sites

this is going to sound stupid but, are the bleed holes clear ?

its not often you have to do such jobs on cars unlike landys.

i am kind of eliminating this myself though as it cant be possible for all of them to be blocked ??

maybe its the failed component thats causing the whole issue :-/ ......stating the obv

Link to comment
Share on other sites

Yeah, took the bleed nipples out and the holes in the calipers look clear.

I am going to get a master cylinder tomorrow and replace that as I am completely out of all other ideas! Not convinced it will make any difference though, as I can get fluid pushing from it and out of the abs block. If everything was blocked I should get pedal pressure even if I can't bleed it? Never, ever had this before.

Link to comment
Share on other sites

Stupid question but have you tried to reverse bleed it?

I use an old pump type oil can just for this and a small length of rubber hose from spout to nipple and pump until res is full, it saved me loads of headaches on the old LWB series TLS, might be worth a look? if something like a bias valve is blocking it then pushing it backwards might allow fluid to go in the right direction?

Link to comment
Share on other sites

I haven't tried that. Will give it a shot in the morning as I've nothing to loose. There is no bias valve for the fronts but you never know, it might free some crud if there is a blockage or five anywhere!

Actually it migh "back flush" the master cylinder which could free any crud if that is a problem.

Good thinking, thanks.

Link to comment
Share on other sites

drums or disks on the rear? i know it's irrelevent when it comes to bleeding but i had similar on my pug (loosing pressure intermitently then no pedal, was a weeping rear cylinder letting air in. I've always found bleeding abs equipped vehicles a pain, usually have success with engine running and pumping the pedal. I will say i did once have a vectra, had absolutely no brakes at all to the rear, but had a good firm pedal, turned out the abs pump had stuck and wasnt allowing any fluid to the rear.

Link to comment
Share on other sites

Well it's done, finally!

New master cylinder and rear brake caliper fitted. Didn't go without it's problems though. The pressure bleed still didn't work, and the reservoir actually cracked (not at a seam but on the top!). I was only using a mountain bike tyre with about 15psi as well, to keep the pressure down!

Thankfully I'd got another reservoir with the master cylinder. Bled it the old fashioned way and finally got there.

No idea why the pressure bleed doesn't work on the A4?? It pushes fluid into the reservoir but no further.

As I say, all done now but what a chew on. If anyone has any idea why the pressure bleeder wasn't working I'd like to know, never had a problem with it before and testing it off the vehicle it works fine. Never split a reservoir before either!

Thanks for the tips above. Think I will chalk this one up to an "unkown" and hope it never happens again :ph34r:

My top tip, don't use a pressure bleeder on an Audi :glare:

Link to comment
Share on other sites

If it's the same as my '02 A3, if you push the pedal all the way to the floor, when conventionally bleeding, you invert the seal on the piston, and then it's fubar'ed.

Added to that, you need VAG-COM or dealer software, to get the ABS pump to run up, and purge itself of air, once you've run the fluid low. You can't just use a pressure bleeder.

As I say, that's the A3, but a brief google suggests similar issues for the A4.

Link to comment
Share on other sites

If it's the same as my '02 A3, if you push the pedal all the way to the floor, when conventionally bleeding, you invert the seal on the piston, and then it's fubar'ed.

I think this is likely to have happened. I shall know for next time I guess! There isn't a bleed nipple on the master cylinder. Turns out (google) that audi brake fluid reservoirs are prone to cracking with as little as 10psi pressure.

I did disconnect the battery as recommended in the Haynes manual, something to do with the ABS it says.

Good news is it's still feeling better than ever now!

Link to comment
Share on other sites

Similar issues with the skoda octavia - probably similar mc and abs, didn't have the software or cable, so had to prompt the abs pump to run on a gravel track to get the air out. I used a vacumn bleeder in combination with the pressure type to resolve it.

Steve

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy