Jump to content
jwhitton

300TDi - front washer question

Recommended Posts

Hello All,

My Defender 300TDi washer jet plastic top has come off.

Not sure if it should come off or it has broken off!

When I push it back on it does not secure itself and I cannot see how it should fit back on.

Has it broken, or am I just being stupid on how it fits?

If a new one is required, how is it fitted?

Please help! Thanks in advance.

Jon

post-4323-0-37418100-1364903109_thumb.jpg

Share this post


Link to post
Share on other sites

you need a new one, you get at it by taking the top of the dash out.

Better still fit one in each of the spare gromets under your wiper arms, you get alot more water on the screen.

Share this post


Link to post
Share on other sites

If you have very small hands you can replace the jet thro the hole where the ashtray fits on top of the dash. It's a bit of a bugger but much easier than taking the dash top off.

Share this post


Link to post
Share on other sites

Bit of a PITA to change I'm afrad, as VB says you have to remove the dash to get to it form the inside.

Mav

Share this post


Link to post
Share on other sites

Or do as I did and jam an aquarium "t piece" into the hole where the jet has broke and fix 2 lengths of aquarium tubing to it (one per wiper arm). Then find a couple of Peugeot 405 spray bars and cable tie them to your existing arms.

These then spray 4 jets of water directly in front of each wiper blade.

Share this post


Link to post
Share on other sites

Good idea, (but not sure my wiper motor would be capable of bending the aquarium tubing)

Share this post


Link to post
Share on other sites

Dont wish to hi-jack your thread, but on a similar issue- I have a TD5 -90 where I set up the washers to both be perfect on the middle of the front screen-- then after about a week one of them sprays underneath the wiper and the other one sprays over the top of the screen and hits the car following! or dribbles weakly and doesnt even reach the screen!! Funnily enuf the rear wiper never seems to mal-function, and the washer hits the rear screen plumb centre every time. Should I switch the rear washer for the front? LOL. Any remedies welcome.

Share this post


Link to post
Share on other sites

That happened to one of my ones 2 years ago, the nozzle froze and dropped off. I just superglued it back on and it lasted for a year till I did a complete rebuild of my Defender.

Share this post


Link to post
Share on other sites

if you only use just water in your squishers then you get mold growing in the tank which every so often ditatches and blocks a hole. Best thing to do is clean the tank and pipework, then always put some kind of detergent in the water, I've never had a problem.

Mav

Share this post


Link to post
Share on other sites

Thanks very much.

I sometimes use pre-mixed screen wash but if I run out I have been guilty of filling up with just tap water.

Will clean it out when it warms up a bit outside. Flippin freezin again today!

Cheers

Studmuffin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy