Jump to content
Andrew Cleland

TD5 engine vibration around 2,500rpm

Recommended Posts

I have a 110 Td5 which has a very strong, worrying vibration at around 2,500rpm (no rev counter, so working back from the speed using Mr Ashcroft's calculator). The vibration occurs even in neutral, so I'm pretty sure it's engine and not gearbox/prop shafts/etc. - I have read that the natural frequency of the Td5 is around 2,200rpm so a failing damper can cause problems, I've also read about engine mounts (but I can't imagine the engine is supposed vibrate like that and the vibes just isolated from the rest of the vehicle either).

I'm hopefully going to get it hooked-up to a Nanocom to see if there are any fault codes (it does occasionally stumble & check engine light comes on, for a few moments than keeps going normally).

Any other ideas, advice?

I've uploaded a video but to be honest you can't really get a sense of the vibrations from the video - around 18mph in 1st and then around 28mph in 2nd (there's a 1.2:1 transfer gear in by the way).

Cheers,

Andrew :)

Share this post


Link to post
Share on other sites

any coloured smoke out the exhaust?

Does it make any difference if its hot or cold?

Share this post


Link to post
Share on other sites

Ok, had a play just now - happens both cold and hot engine and no sign of smoke that I can see (having to use mirrors from drivers seat as my helpers are all away).

A.

Share this post


Link to post
Share on other sites

Check over the pulley/damper/balancer on the front of the crankshaft. It's a 2-part thing - with bonded-rubber between the 2 halves.

If the metal-to-rubber bonding weakens and comes free it can make things nastily-vibrational.

If that's OK, the next step gets expensive because it involves dropping the gearbox and investigating the condition of the dual-mass-flywheel.

My experience with something like ten fleet TD5s is that the younger drivers who instinctively change-down-early-and-use lots-of-revs can easily take a DMF and clutch to 200,000 miles.

Older types - conditioned to 'get it into the highest gear as soon as possible' will knock-out a damper/pulley/DMF in 50,000 miles and a gear/transfer-box in 80,000 miles. Shock-loadings increase a lot at low-RPM.

[Data-loggers which record speed/gear/RPM are the fleetmaster's friend]

Share this post


Link to post
Share on other sites

Check over the pulley/damper/balancer on the front of the crankshaft. It's a 2-part thing - with bonded-rubber between the 2 halves.

If the metal-to-rubber bonding weakens and comes free it can make things nastily-vibrational.

If that's OK, the next step gets expensive because it involves dropping the gearbox and investigating the condition of the dual-mass-flywheel.

My experience with something like ten fleet TD5s is that the younger drivers who instinctively change-down-early-and-use lots-of-revs can easily take a DMF and clutch to 200,000 miles.

Older types - conditioned to 'get it into the highest gear as soon as possible' will knock-out a damper/pulley/DMF in 50,000 miles and a gear/transfer-box in 80,000 miles. Shock-loadings increase a lot at low-RPM.

[Data-loggers which record speed/gear/RPM are the fleetmaster's friend]

Cheers, I'll take a look at the damper assembly on the front. I guess the Td5 doesn't have a nice flywheel cover plate like a V8 which lets you take a gander at the flywheel...

Motor is ex-Kent police, so hard to say - I guess it depends on the copper who was driving ;)

A.

Share this post


Link to post
Share on other sites

I had vibration on my TD5 around same speed under acceleration which was the turbo waste gate seized.

Have you checked that?

Thanks morgan - it's a possibility definitely. V8freak and I had a look at it a couple of nights ago and the wastegate was pretty stiff - I'm giving the actuator daily doses of penetrating oil. V8freak has very kindly lent me his Nanocom so I can watch the boost pressure on the Nanocom and see if it's link to the vibes. Neill also lent me viscous fan spanners so I shall take the fan off tomorrow and have a look at the damper pulley.

A.

Share this post


Link to post
Share on other sites

I had to remove the ally heat shield and apply half tin WD40 and mole wrench it gently til it moved fully.

I couldn't believe the difference.

Here's hoping; simple and cheap fix if it is.

Share this post


Link to post
Share on other sites

So I spent a couple of hours with the Landy on Saturday (makes it sound like a 'relationship', which isn't entirely inappropriate...).

Started with the damper - put the big spanners onto the viscous fan to remove it and while trying to position them for belting with a hammer the fan came undone - it wasn't exactly loose but it certainly wasn't big spanner and hammer tight. Anyhow, took the fan off, released the belt tension and had a good feel of the crank pulley (oh er missus, etc.) - it felt fine, no obvious play either rotational or big-forth. Not having a replacement bolt or much time, I decided against taking the pulley off for a closer inspection.

Next I took off the cam cover and checked that the injector codes matched the ECU settings, which they did. I also checked the injector clearances - cylinder 2 was a little on the loose side, almost two turns from the plunger being seated, the others were all pretty fine.

Finally I took a look at the wastegate. I managed to get the actuator rod disconnect from the wastegate and the wastegate itself was moving very freely, no stiffness at all. The actuator seems OK, moves if you pressurise it with a bike pump. I gave it a drop of oil anyhow and put it all back together - didn't change the adjustment on the actuator rod at all.

Outcome is that tightening that injector pump seems to have removed a slight tappety noise at idle. I *think* the vibrations may have lessened as well - there still is something there which I noticed overtaking a Freelander(!) but I didn't have the Nanocom connected so it may just have been reaching revs that Td5s don't like - it did seem to be higher up the rev range. (I've slightly screwed-up my diagnostics by installing a Wright Offroad soundproofing kit as well, so everything is quieter than before - I had one in my old V8 110 and they really are good).

One thing that I am curious about is that I don't seem to be reaching full boost - it should be over 200kPa I think before the wastegate opens. We don't have many hills here to test it but even flooring in third doesn't get much over 120kPa. I can also hear hissing compressed air as I work up through the gears - is this normal or is there a leak (it sounds cool, a little like a dump valve, but I'm not sure it should be there)?

A.

Share this post


Link to post
Share on other sites

So I spent a couple of hours with the Landy on Saturday (makes it sound like a 'relationship', which isn't entirely inappropriate...).

Started with the damper - put the big spanners onto the viscous fan to remove it and while trying to position them for belting with a hammer the fan came undone - it wasn't exactly loose but it certainly wasn't big spanner and hammer tight. Anyhow, took the fan off, released the belt tension and had a good feel of the crank pulley (oh er missus, etc.) - it felt fine, no obvious play either rotational or big-forth. Not having a replacement bolt or much time, I decided against taking the pulley off for a closer inspection.

Next I took off the cam cover and checked that the injector codes matched the ECU settings, which they did. I also checked the injector clearances - cylinder 2 was a little on the loose side, almost two turns from the plunger being seated, the others were all pretty fine.

Finally I took a look at the wastegate. I managed to get the actuator rod disconnect from the wastegate and the wastegate itself was moving very freely, no stiffness at all. The actuator seems OK, moves if you pressurise it with a bike pump. I gave it a drop of oil anyhow and put it all back together - didn't change the adjustment on the actuator rod at all.

Outcome is that tightening that injector pump seems to have removed a slight tappety noise at idle. I *think* the vibrations may have lessened as well - there still is something there which I noticed overtaking a Freelander(!) but I didn't have the Nanocom connected so it may just have been reaching revs that Td5s don't like - it did seem to be higher up the rev range. (I've slightly screwed-up my diagnostics by installing a Wright Offroad soundproofing kit as well, so everything is quieter than before - I had one in my old V8 110 and they really are good).

One thing that I am curious about is that I don't seem to be reaching full boost - it should be over 200kPa I think before the wastegate opens. We don't have many hills here to test it but even flooring in third doesn't get much over 120kPa. I can also hear hissing compressed air as I work up through the gears - is this normal or is there a leak (it sounds cool, a little like a dump valve, but I'm not sure it should be there)?

A.

Hi ...did you fix the problem..I am having exact same issue with my TD5 its impossible to live with over 60mph

Share this post


Link to post
Share on other sites

Hi ...did you fix the problem..I am having exact same issue with my TD5 its impossible to live with over 60mph

Me too. I know it's digging up a old post...

Share this post


Link to post
Share on other sites

The hissing air sound could be the well known td5 warped manifold problem - which will also lose you boost.

Check the manifold - head joint at the front & back of the engine for exhaust soot & be prepared for broken / loose manifold retaining studs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy