Jump to content
alex-the-lyon

Very High Idle 2200rpm - P38 V8 in LR90

Recommended Posts

Hello Everyone

I'm new to this so sorry if this has already been covered...

Ill start with the back ground...

Got a Landrover 90 (E reg) which we fitted a 4.0l P38 engine in to and upgraded to MS1 & EDIS at the same time. When we fitted the engine we never fitted the PWM valve and just relied on right foot when starting! It ran fine for a year or so until we blew up the engine.

We have had the engine rebuilt for us and now it is fitted (now with the PWM Valve) it will start and idle at about 1600 rpm and as the engine warms up the tick over drops until the temperature reaches about 80 deg C at which point the engine will rapidly rev up and idle at 2200 rpm!

I have checked everything and am now totally baffled! We have done:

- checked for air leaks (pulled off all pipes and plugged them)

- disabled PWM and plugged inlet

- checked throttle poss in ecu & in plenum

- re loaded the map from Nige

- checked idle in ECU (set at 850)

- Totally closed the idle control in plenum

Any one have any ideas? Im totally baffled! I can send the map to anyone if they want to check it out.

Thanks in advance!

Share this post


Link to post
Share on other sites

Just wondering if you ever solved your problem of high idle? I'm having similar problem.

Share this post


Link to post
Share on other sites

The PWM valve need current to hold it shut, I am sure that was what was happening here, MS had not been set up properly yet.

 

lOn a normal engine ECU, high idle is mostly caused by either a logged fault code,or more often an air leak on the inlet somewhere. Other possibles are things like the throttle butterfly being jammed open.

 

Need more info really.

Share this post


Link to post
Share on other sites

Ah OK.

Bowie, I have read a lot of your posts and you seem to have a good handle on things, can I ask a question relating to the above high idle. I have MS1/EDIS/PMW so do not use standard stepper. I read that this redundant part may not be sealed leading to an air leak. I took mine off and put a sealant on and reattached. It didn't make a difference. On further reading I now wonder if the old stepper rests in an 'open' position thus actually requiring me to seal it internally and not just around the connection? Have you any idea? tks

 

Share this post


Link to post
Share on other sites

Hi again,

I found a post that I thought I had read before but couldn't find where you answer the problem. I guess I have to figure out how to block off internally..... don't suppose you ever came across how to do it? I will have to find an internal diagram or something to see where air flow goes so that I block it correctly.

 

Share this post


Link to post
Share on other sites

The stepper idle valves are not usually "self aware" - they don't have any idea what position they're in. They don't spring closed, so when the engine is switched off they will stay wherever they rest. When powered up (or sometimes powering down) , the ECU will spin the stepper motor enough to ensure the valve is fully closed (or open) , then back up a certain amount of steps, and ensures the ecu then knows where the valve is as it keeps a count of the steps. This is quite different to the spring loaded solenoid valve idle control that's driven with a pwm signal and commonly set up with MS. 

https://www.diyautotune.com/support/tech/other/stepper-iac/

MS does support idle stepper control, and I have done so on one of my installs, though I forget which. It's really not hard to configure, and more repeatable the PWM method IMHO. 

Share this post


Link to post
Share on other sites

Tks hi lo, but I am not trying to get the stepper working as I have a PWM, I think I simply need to close off the old stepper to stop air leaking in to plenum causing high idle.

However, you might confirm, as the stepper is no longer wired up, I presume it is not as simple as sticking 12 volts across the terminals to put it in the fully closed position.

Tks

Share this post


Link to post
Share on other sites

Exactly, you need to block the port in the plenum, behind the stepper, shame the OP of that thread never posted a photo, but it is in there :)

Share this post


Link to post
Share on other sites

^ Exactly, this comes up so often.

The stepper motor is just that - a motor that moves one step every time the ECU sends a pulse. What it doesn't do is self-close or just run when power is applied like a regular DC motor, you have to send pulses to the right coils in the right order to step it around in a circle. As standard, MS1 doesn't support this although it's possible (anything's possible!), plus it requires 4 wires to make it work, that's why the simpler 2 or 3-wire  PWM valves are used.

The stepper idle valve is just a stepper motor connected to a plunger that moves in & out to block or open a hole for air to get through - in order to give the ECU enough range of control over the engine it can open and close a lot further than needed in normal operation - and the ECU will leave it a bit open when you switch the engine off as it knows the next thing it'll be asked to do is start the engine, which needs some air.

So, it's not enough to just disconnect the wires as you're leaving the thing in an open position, you've got to block its air passage so you're not creating a "bypass" to the throttle plate and your shiny new PWM valve.

Here's how I blocked one of mine with a machined bung:

IMG_9291.JPG

I made a small plate to cover the mounting hole.

Share this post


Link to post
Share on other sites

Tks for the info.

It is good to know what I have to do even if I don't know how to do it.

FF, I will have to make sense of your photo and have a look at mine as I don't think that I have a hole where you appear to have slid in the cylinder in. But maybe it is there and I just have to drill it out. 

Cheers guys

Share this post


Link to post
Share on other sites

That's a 4.0 / 4.6 plenum and yes I popped a blanking plug (core plug) out in order to slide the pin in - I put a bit of silicone around it to give a good seal.

3.9 has a different setup but the idea is the same - block the airway with something that can't be spat out or sucked in to the engine.

Share this post


Link to post
Share on other sites

Mine is 3.5 but will have a look and see tomorrow what I can come up with. Tks again.

 

Share this post


Link to post
Share on other sites

It was a flapper originaly but now PWM. But actually I just realised that I got another plenum/manifold from Nigle when I bought it so it is actually a 3.9 plenum. Either way I didn't notice hole there. 

Share this post


Link to post
Share on other sites

The hole is blocked off on mine, so I drilled it out. Your photo gave me the  confidence! I shoved a rubber pipe in to see if it has sorted the problem and I think it might. :)

So, I thought I would put some photos up to help someone else in the same situation.

I now have to try and tap it, not sure if I have a big enough tap, or find some other solution. I will post again when successfully completed.

Again, thank you for help.

Plenum stepper before.jpg

Plenum stepper during.jpg

Share this post


Link to post
Share on other sites

I attempted to undertake this today and thought I would put up some info for any others who might come across this problem.

I did not have a tap large enough so I got a bolt which fit snugly in through the first hole and slid into problem hole. This took a bit more drilling out to get the same size drilled hole as the inside one. I slid bolt in through new drilled hole and then put sealant on it and slid it in on into the corresponding air hole opposit it inside, which is where the air was leaking. Hopefully this will give as close to air tight as I could.

I cut the mechanism off the end of the stepper motor, then attached a metal plate with sealant where old stepper hole was and then used old stepper (now with flat bottom) to fix in place. 

I forgot about taking photos of each specific stage but the following will show the bolt in situ (with probably too much sealant making it look very messy) and then the finished photo showing the old stepper holding a metal plate, which you can just see the corner sticking out.

So hopefully all sealed up now. I couldn't check as I have no oil or water in the engine as I am also working on oil pump plate.

Anyway, I will follow up with results when it is up and running to close off but obviously this or something like it needs to be completed by anyone switching to PWM from plenum stepper configuration.

Fingers crossed.

20190408_113346.jpg

20190408_112547.jpg

Share this post


Link to post
Share on other sites

Just to confirm it worked. Thank you guys sooooo much. I can now enjoy the fun bit of tuning and getting back on and off the road.

A possible side effect may be that the idle screw may have been blocked at the same time. It is now making no change even when screwed fully shut or removed altogether. Don't know if anyone else has had this issue. I need to investigate it's air path and figure out if I have sealed it aswell! 

Anyway, that is a problem for another day. Thanks again. 🖒

  • Like 1

Share this post


Link to post
Share on other sites

Good news, thanks for coming back to let us know :)

I'm not completely familiar with that plenum, so couldn't tell you if the air bypass screw would now be blocked.

Share this post


Link to post
Share on other sites

I'll investigate and post if I figure it out. Tks.

Share this post


Link to post
Share on other sites

Hi guys,

Its been a little while but I have an update. I don't feel I have the expertise of FF, but I will tell you what happened to me.

After my last work the high revs were cured but became a low revs problem and I was unable to change with bypass screw.

I investigated and found that by putting the bolt in where I did and sealing the hole identified in photo below, I stopped all air bypassing the butterfly. The upshot being the bypass screw could be taken out completely and it made no difference whatsoever.

image.png.51fa7b9c0e9c40811860b2072393044a.png

So I took it apart and investigated. I found that I needed to keep this passageway (above photo) clear as this is the only air inlet connecting before and after butterfly.

What I have done now is remove this new bolt, clear this hole and instead fill the hole at right angles to this one, the one that goes through into the mouth of the plenum (see second photo below). I have tried to show a representation below because I forgot to take a picture when I had it apart.

image.png.4e7e6ac152b0b5cfa2ec342e14d3c82f.pngimage.png.3a3f4595547696aeea0905809cae436e.png 

It now allows me to alter the revs up and down via the bypass screw and I have now been able to get the idle tuned correctly (I hope!!) to the lowest MAP and then be able to bring revs back down mechanical with bypass screw to 800 revs

So this appears to be what has now worked for me, so I thought I should update post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy