Jump to content

aftermarket gauge problems


Recommended Posts

Hi all, iv fitted an oil sandwich plate and oil temp and pressure gauges to my 110, so far, apart from the odd oil dribble, its been working great, however if i turn the side lights on or press the brake the pressure gauge dips and the temp gauge rises a bit, turning on the main lights causes the same but dips and riaes further (until the pressure is reading negative), i dont know what to do about this, for the gauge power i spliced into the power for the stock gauges and for the back lights i spliced into the stock backlights wires

Link to comment
Share on other sites

Gauges like, in general, a stabilized feed.

Often, when switching on lights, the gauges will read higher because the voltage drops a bit.

Like he said, separate feed / stabilizer usu do the trick.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy