Jump to content

ex-japanese 300tdi auto edc immobiliser issue


symeon
 Share

Recommended Posts

As the title above, I have a significant issue with my repatriated '98 disco immobiliser.

I did some searching, and although found some similar problems, they dont seem to correspond to my problems fully.

Please excuse the essay, but thought Id include everything Ive tried and found.

The engine is a Japanese '98 EDC automatic, no DDS, no Spider unit.

It started off by intermittently having trouble unlocking the car with the key fob.

Nothing new, took it apart, one of the switches fell off.

Re-soldered another one in its place, sorted.

Now and then, the main beam light on the dash would glow ever so slightly with the dip beams on.

Quick flash of the headlights and it would rectify itself.

Fast forward to Tuesday last week:

Key fob was having a really bad time of unlocking the car.

I could open the car with the key itself, which would unlock all the doors, but the fob was just not having it, even with my rain-dance like movements in the carpark, but I needed to use the fob to disable the immobiliser due to it being EDC controlled.

Finally got in the car, started, put headlights on, slight glow from main beam lamp, flashing headlights didnt work, went home with driver's headlamp glowing dimly, but passenger side as normal.

Wednesday morning:

Went to the car - Nothing happened.

Could open the car with the key, but absolutely nothing from the fob, but it would crank over (checked just in case).

Spent about 2 hours trying to get it to work, and all of a sudden it did, so started it up and went up to my local LR guy to see if he could disable the immobiliser or something to stop it happening until I could get a new fob.

He plugged in his hawkeye, but couldnt find such a function in the system to do so.

Went to go home, and again, nothing.

Sat for about another hour, and finally it came to life, so took it home, and since then its done absolutely nothing.

Battery is ok, was new 6 months ago.

Heavy duty earth cables fitted by me from battery to engine and body/chassis.

Stop solenoid output is working, albeit about 1.5v lower than battery voltage. Also shows around 2v when ignition off.

Solenoid checked out of the pump as working.

All fuses appear ok.

Tried another alarm ecu and fob, which unlock the car, although wont disengage the immobiliser due to not being code linked to the ECU (which I found out after).

Went to program the working fob to the original alarm, but I have no bonnet switch to press with it being a japanese one apparently.

Found there's an input to the alarm ecu for the bonnet switch, which goes straight to earth basically, so spliced a wire in to act as a switch - still nothing.

Out of curiosity, checked continuity of the 'switch', and found a similar 2v coming out of the alarm ecu to what I found at the stop solenoid, doesnt matter if ignition on or off.

Oh, and prior to this issue, it started on first click each time, so not engine related seemingly.

Help.....

Link to comment
Share on other sites

I would have said earth problems would be a place to start but you seem to have done that already. Might be worth checking that the EDC and alarm ECUs have a good earth at the ECU too, in case there is a corroded earth header or something.

If it is a 1998 it should be a two button alarm so would need Testbook or similar to program it, unless the Jap market ones are different but everywhere else went to two button from 1996.

I presume you have changed the batteries in the key fob? CR2032 I think.

Link to comment
Share on other sites

With one of the two fobs I have it is necessary to press the unlock button after I have put the key in the ignition and turned it to position 2. Without the fob will not talk to the sensor in the ignition switch. Our 1996 Discovery no longer has an EDC, it is now on the garage shelf following failure of the throttle position sensor and conversition to a "mechanical" injector pump. However I still need the fobs to operate before it will crank the engine over.

It does rather sound like a poor connection somewhere. Have you checked the engine fuse box, including underneather? Corrosion there can give interesting problems.

Link to comment
Share on other sites

Hi guys, thanks for replying.

Im gonna be going over the car again today, so Ill be checking all the internal earth points and under the fuse box as advised.

Also, after looking up something else last night, Ill be checking the alternator outputs, as if thats going it can output a permanent low voltage apparently.

For information, yes, it is a 2 button fob, and yes, the batteries have been changed numerous times,

When the Hawkeye unit was plugged in the fob wasnt showing as having any RF output, so seemingly the fob is dead, but at the time I didnt have another one to program to it.

Its this low voltage thats bugging me, as it shouldnt really be there, and tbh, the stop solenoid shouldnt be getting full volts if the immobiliser is active anyway should it?

As a side note, does anyone in the County Durham area have a Hawkeye or similar to try and program this new fob for me? Beer tokens are available.

Link to comment
Share on other sites

Well, Im still no further forward.

Even resorted to going to the dealers to get my EKA code (which was free btw), which still didnt work.

The reason I think it didnt work however, is not because of the alarm box, but there's switches in the lock that sense these turns you make, and when we were trying to disengage the alarm with the hawkeye, it was set to turn the immobiliser off by turning the key in the door.... which didnt work.

So if that didnt work, then the EKA is not gonna work either probably.

So now, Im just trying to find someone with a Hawkeye to come down to me, rather than me take it there, and program a working fob into the alarm system, to see once and for all whether its just the fob or something else going on.

Bloody cars!

But, I did get a nice printout of my codes and where it was first sold, which was JLR in Kabushiki Kaisha, just up the road from Tokyo on 27th November 1998.

Link to comment
Share on other sites

  • 2 weeks later...

So, after waiting 3 weeks for numerous independent garages, and so-called auto-diagnosticians to get back to me, or even come to me to sort out my fob problem, yesterday I decided Id had enough.

So I bit the bullet and bought a fob and programmer from RemoteKey.co.uk.

It arrived first thing, and within the 30 seconds they say it takes, my car was de-immobilised and running.

I cant recommend them enough.

Had I just done that 3 weeks ago, I would have been back on the road within 24 hours of my fob dying.

Anyone on the fence wondering whether or not they should use them to get a fob sorted, just do it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy