Jump to content

3.9 EFI fuel restrictor required


rincewind23
 Share

Recommended Posts

Hi all,

TL;DR is: Should there be a restrictor of some sort on the fuel return pipe of a Discovery 3.9 EFI fuel system?

Details follow..

I've started a new topic since 'Dead MAF?' it certainly wasn't.

Recap: I've had a Defender with a 3.9 EFI Disco engine in it for about three weeks - it's been running fine but then yesterday it started messing around - it wouldn't rev when I hit the accelerator. It was intermittent to start with but then went full on broken. I managed to limp home in 1st gear on idle.

I did all the electrical diagnostics (from the original workshop manual), verified the injectors were working etc, bought a fuel pressure tester and plumbed it in next to the fuel pump (30-35psi), all good. I eventually gave up and sent it to a mechanic.

He had it working within 3 hours - he said he'd done all the same tests as me, then somehow stumbled across clamping the fuel return pipe got it working. I went and picked it up, got about a mile away and it went back to the original state - limping along on idle. Only now when I got it back to him clamping wasn't fixing the issue.

He said it needed a new fuel pressure regulator (even though this one works on the 3.5 v8 in my kit car, also from a Disco), so I bought one, he fitted it, same issue. Then he said it must be the fuel pump, so I bought a new external one and the long pipe to feed it from the bottom of the fuel tank.

He got back to me today to say that it now runs again when the return pipe is clamped. So, it seems like the fuel is running out too quickly. Is this likely? Should there be a restrictor of some sort on the return pipe?

I did have the fuel tank out to replace the gearbox bushings, and there was a piece of rubber hose laying in the bottom of the fuel tank. However, since it ran fine before/after the refit I didn't think anything of it (apart from googling around and not finding any forum posts, references or pictures of similar).

Cheers,

Kev.

Link to comment
Share on other sites

The pump should provide fuel at pressure to the fuel rail, and the regulator should maintain that pressure by venting the excess back to the tank.

Given that you seem to have ruled out pressure/pump/regulator, I wonder if there is air getting in to the system which will certainly upset things.

Link to comment
Share on other sites

It's been a while since I messed about with standard setups but that fuel pressure sounds too low for an EFi, I usually run mine up at around 55-60PSi but I don't know off hand what a standard RV8 would run at so it may be OK.

Anyway, it all sounds like a lack of fuelling, restricting the return will boost the fuel rail pressure and richen it up. There are two possible reasons for it running lean, lack of fuel or too much air.

With the above in mind, the first thing I'd do is make sure you haven't got a split pipe in the air system somewhere. Any air getting into the inlet manifold which bypasses the MAF sensor will weaken the mixture.

If it's not too much air then you're not getting enough fuel and that can be down to either a "mechanical" issue such as low fuel rail pressure, an electrical problem (bad earths on the injectors, for example) or a calculation problem. Most calculation problems can be detected using the standard fault finding tests using a multimeter at the ECU plug.

One last thing, given that you have disturbed the fuel tank, can you confirm you have a filter before the regulator ? If so then you may want to change that as it might be restricting the fuel flow and if you haven't then you may need to get the injectors cleaned as they may be partially blocked.

Link to comment
Share on other sites

Thanks for all the replies.

The fuel pump I bought was from ebay - 'Lucas type 4FP replacement Fuel Pump'. The ad said it was rated @ 3 bar - 2.54 KGF / cm3 - 36.25 lbs / square inch (and I only just realised that 3 bar is way more than 36psi!). When I run without a return restriction, my pressure gauge (plumbed in at the pump output) reads at around 30psi. I've now got a jubliee clip on the return line restricting the flow just enough to get the engine running smoothly.

I forgot to check if there are any air leaks.. I'll do that tomorrow and post back.

 

Cheers,

Kev.

Link to comment
Share on other sites

General specification data in the WSM says:

 

FUEL SYSTEM 3.9 V8i


Fuel system type Lucas 14CUX hot wire system electronically controlled

Fuel pump-make/type ACX delco high pressure electrical, immersed in the fuel tank


Fuel pump delivery pressure 2.4-2.6 bar (34-37 lbf/in 2 )


Fuel filter Bosch in-line filter ’canister’ type


Airflow Sensor
Make and type Lucas ’Hot Wire’ 5AM


Injectors
Make and type Lucas 8NJ


Electronic Control Unit
Make and type Lucas 14CUX


Fuel pressure regulator
Make and type Lucas 8RV


Fuel temperature sensor
Make and type Lucas 6TT


Coolant temperature sensor
Make and type Lucas 3TT


Bypass Airvalve (Stepper motor)
Make and type Lucas 2ACM


Throttle potentiometer
Make and type Lucas 215SA


Lambda sensor - catalyst vehicles
Make and type Lucas 3LS

 

Plus:

 

Fuel pressure regulator

The fuel pressure regulator is mounted in the fuel rail at the rear of the plenum chamber. The regulator is a mechanical device controlled by plenum chamber vacuum, it ensures that fuel rail pressure is maintained at a constant pressure difference of 2.5 bar above that of the manifold.
When pressure exceeds the regulator setting excess fuel is returned to the fuel tank.

Fuel pump

The electric fuel pump is located in the fuel tank, and is a self priming ’wet’ pump, the motor is immersed in the fuel within the tank.

 

Testing fuel pressure:

 

fuel.jpg

 

Link to comment
Share on other sites

Thinking outside the fuel system, have you checked coolant temp sender, fuel temp sender, MAF etc?

If these are reading really wrong it may be trying to lean things up, and by clamping the return all you are doing is forcing it to run rich(er) than it thinks it should be.

I'd run through the hotwire diagnostics in the tech archive and see what's what.

Link to comment
Share on other sites

Bogmonster,

I have run through that fuel pressure check (didn't realise that it was the test process in the book, but had done it anyway) with three different pressure regulators - the original one on the car, the one from my 3.5 v8 (from a Disco) that's in my kit car (both of which work fine in my kit car), and a brand new one that the mechanic made me buy and fit to verify it wasn't the culprit, and all three get up to pressure when switching to position II, but immediately drop back to zero after the 2 second priming period turns the pump off again (for which I've seen conflicting information on the forums - some people agree with the pic you posted, some people say theirs drops to zero and the engine runs fine).

As a side note my fuel system doesn't have a filter; the guy who had it before me obviously decided it didn't need one. This is on my 'to fix' list.

Bowie69,

I've run through the hotwire diagnostics steps (including taking the fuel rail off to test the injectors!) and everything is correct according to the document. I've hooked up rovergauge to the 14CUX and the temperatures seem to be ok - well the coolant temp seems ok, I'm not sure what the fuel temp should be to be 'normal' :)

As far as I can tell the MAF is good. I've swapped it with the 3AM off the other engine with the same result, although I megasquirted the other engine so the MAF has been in a box for a while. I'm not sure how to test the MAF, and I don't have a known good one to test with.

 

So now, I think my 'to test' list looks like:

Air leaks between the MAF and the plenum

vacuum to the pressure regulator

MAF (other than the tests in the hotwire diagnostics)

 

 

Link to comment
Share on other sites

I have checked; there are no air leaks to the plenum, the hose is good and tightly connected at the plenum and at the MAF.

I checked the vacuum tubes. The FPR tube was a little loose so I swapped it out for one that fits tightly at the FPR end, and is secured with a jubilee clip next to the idle valve.

The vacuum advance to the dizzy had splits in the boots at both ends, so i've replaced those with some tight fitting tube.

I put the original FPR back on and managed to get it to run for a couple of miles, before it went back to misfiring. I managed to get home before it went totally dead and now it's back to the original 'idles ok but revs poorly' state, even after leaving it overnight to cool down. I pulled the plugs and cleaned them yesterday; they were all very sooty, but 2,3,5,7 and 8 were starting to get sandy brown at the tip from the bit of good run I got. 1,4 and 6 were still fully black. I doubt this will indicate the fault but I just wanted to include all the info I have..

 

 

 

Link to comment
Share on other sites

Hi again,

I'd like to close this topic out, and thank everyone for their input. I managed to get it to driving with the stupidly high fuel pressure, but it was running really badly. After a decent (10-15 mile) trip I pulled all the plugs again, and two of them were clean. Not wet, not sooty, not sandy, just clean. I guessed that change of fuel pump (to the external one with no filter) and the fact there was no other filter in the fuel line may have blocked the injectors. I swapped them with a couple of injectors from my kit car and it started running properly (at normal pressure)!  So whatever the initial issue was, swapping bits around caused a different problem.

Needless to say I now have a separate inline fuel filter, and there seems to be a ton of carp in the fuel tank that must have got through before I fitted the inine filter. Looking at the original in-tank fuel pump, it looks like I may have ripped the filter bag around the input of it, which may have let carp into the injectors in the first place. All I can say is, it works now..

 

Thanks again, all!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy