Jump to content

jwc

Getting Comfortable
  • Content Count

    8
  • Joined

  • Last visited

Everything posted by jwc

  1. I have a 2002 td5 defender 90. When you reach between 65/70 mph it feels as though the engine has limiter the turbo seems to stop working.If you stop and start again the engine is fine and the turbo is working. Any ideas it has just had a new genuine rr airflow metre fitted .
  2. 2002 td5 loosing presure in the fuel line pump having to be primed if left for more than an hour new fuel pump fitted. Someone has told me it could be head gasket. Has anyone any ideas or has this happened to anyone else
  3. Td5 2002 Defender 90, air getting into the fuel system, loosing presure & hard to start, fuel pump renewed & still noisy, any ideas ?
  4. TD5 2003 MODEL FITTED NEW FUEL PUMP. NOW WHEN LEFT FOR MORE THAN A FEW HOURS IT IS HARD TO START WITHOUT GOING THROUGH THE PRIMING METHOD. IT SEEMS TO BE LOOSING IT'S PRESSURE AS YOU CAN HEAR THE PUMP PRIMING ITSELF.IS IT A NON RETURN VALVE SOMEWHERE?
  5. 2002 defender td5 cuts out no power or electrics everything is dead.Leave power back and car starts and runs .When it cuts out engine management light comes on alarm sounds
  6. the lights on the auto gear selector has stopped working. bulbs and fuses are all ok.any ideas
  7. RANGE ROVER CLASSIC 1993 THE WATER LEVEL WARNING LIGHT KEEPS FLASHING EVEN WHEN THE WATER LEVEL IN THE EXPANSION TANK IS AT THE RIGHT LEVEL. I HAVE JOINED THE WIRES TOGETHER AND THE LIGHT STILL FLASHES.ALSO THE LIGHTS FOR THE AUTOMATIC GEAR SELECTOR HAS STOPPED WORKING THE BULBS HAVE NOT BLOWN NOR HAVE ANY OF THE FUSES ANY IDEAS ON BOTH TOPICS
  8. 1993 range rover classic 3.9 when starting from cold the car fails to start and the spark plugs are flooded with petrol. When you finally get it started it runs and starts fine. Could anyone tell me the problem
×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy