Jump to content

windscreen wipers D1 300tdi


GERTRUDE-M
 Share

Recommended Posts

A very similar question was posted in May by SOTAL, but no reply was forthcoming then.

Does anyone have an idea on this: On intermittent wipe the blade parks in one of 4 positions, the correct place and three others, one right in the line of sight, which is a nuisance. It goes through the cycle on successive wipes, so it's not random, but systematic. The wipe-frequency rotary switch on the arm has no effect; it does not work.

On continuous wipe, everything performs correctly on normal- and fast-.

On single wipe, it parks where I make it park.

I had a look in Haynes wiring circuit diagrams and there seems to be a Multi-Function Unit that has to do with the wipers, located behind the driver's side footwell wall, the manual says. It also has connections to the window controls and I do have an intermittent fault with the rear windows too.

Does anyone have any ideas on this, please, and do you think that MFU may be linked to both faults? Ideas would be gratefully received; Thanks

Link to comment
Share on other sites

A very similar question was posted in May by SOTAL, but no reply was forthcoming then.

Does anyone have an idea on this: On intermittent wipe the blade parks in one of 4 positions, the correct place and three others, one right in the line of sight, which is a nuisance. It goes through the cycle on successive wipes, so it's not random, but systematic. The wipe-frequency rotary switch on the arm has no effect; it does not work.

On continuous wipe, everything performs correctly on normal- and fast-.

On single wipe, it parks where I make it park.

I had a look in Haynes wiring circuit diagrams and there seems to be a Multi-Function Unit that has to do with the wipers, located behind the driver's side footwell wall, the manual says. It also has connections to the window controls and I do have an intermittent fault with the rear windows too.

Does anyone have any ideas on this, please, and do you think that MFU may be linked to both faults? Ideas would be gratefully received; Thanks

Link to comment
Share on other sites

Don't know if this will help, had a problem with park position on my 300tdi.

It didn't know it was at the bottom and just kept on going, then sometimes it would stop correctly.

Changed the wiper motor ( second hand one for about £20) cured the problem :)

Link to comment
Share on other sites

Don't know if this will help, had a problem with park position on my 300tdi.

It didn't know it was at the bottom and just kept on going, then sometimes it would stop correctly.

Changed the wiper motor ( second hand one for about £20) cured the problem :)

Thanks SLABSIDE, was replacing the motor an easy job? The manual suggests it might be quite complicated.

Link to comment
Share on other sites

Thanks SLABSIDE, was replacing the motor an easy job? The manual suggests it might be quite complicated.

Pretty straightforward job if I remember. All done from under the bonnet, just step by step.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy