Jump to content

drive problems, gearbox fault


gruffboy
 Share

Recommended Posts

Recently had gearbox fault appear on my dash. 1996 Range Rover 4.6 HSE. Lost drive in forward and revers gear until i rev the engine hard then it clunks into drive. There seems to be no drop in engine revs when i select 'DRIVE' or 'REVERSE'. Auto box, clean fluid can anyone help..........

Link to comment
Share on other sites

Have a look at the FAQ section of http://ashcroft-transmissions.co.uk I wonder if you have low fluid level or the filter screen is partially blocked?

Many auto box faults can be solved by draining & replacing the fluid and the gearbox filter. Don't know about clearing fault codes though.

BUT Ashcroft also make the comment that changing them can cause problems. In your case you have little to lose.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy