Jump to content

P38a R/R Hevac Controls (again)


Recommended Posts

I have a 2001 P38a Range Rover.A year ago I got the dreaded Log Book symbol in the HEVAC dislay.No driver side temp change was possible.Rovercomlite showed the "Right hand blend motor shorted to positive". I replaced the blendmotor,cleared the fault log with Rovercom-everything good.

Now the fault is back but this time the diagnostic tool reads "The RH blend motor potentiometer feedback circuit has failed".This I'm sure is the wiper terminal on the small "pot" that the motor drives.

So I went through the tedious process of getting the Blend motor out! This time I used one of the two other motors that came with the RH blend motor set and wired it to the hevac connector without installing it to blend flap.Everything was fine except if you took the temp control above 28*C to "HI" and tried to cycle back -the fault and the diagnosis and logbook symbol reappeared.The other new motors did the same thing when wired to the RH blend terminals.

Bench testing the motor (and the other new ones) with a 6volt lantern battery and a resistance meter across the "pot" wiper to the other end showed every thing was fine.(0-10Kohm)

I concluded the HEVAC control must be faulty so I bought a used one off eBay (said to be in perfect order).Installed the used unit but soon as I went to "HI" with the RH temp switch the fault returned on all substituted motors.Every other aspect of the used HEVAC seemed OK.

In case there was an issue with not having the Blend motor mounted and moving the flap I re installed it but same fault.

I was able to clear the fault by setting the RH temp to 20*C and having Rovercomlite "clear all faults".This way I could get fresh faults.

My conclusion is either I've got two faulty Hevacs or there are some tenticles from the HEVAC ECU back into the Main BeCM that could be sending bad calls to the HEVAC.

At about 260pounds for a new HEVAC I want to be sure it is the culprit!

Anyone got an idea? Thanks

Link to comment
Share on other sites

You have never mentioned calibrating anything. Did you?

The HEVAC ECU needs to see the feedback results when it 'knows' the flaps are jammed against the stops at both ends of the range. It is these values, and ONLY these values, that it uses to confirm the flap is at the correect position.

This explains why you only see a fault on HI (or occasionally (LO), unless the motor / flap stops part way through a mechanical jam.

You can get away with changing motors and not calibrating them (I have, on both LH and RH blend motors), but it's the obvious 'next thing' here.

This is also why testing the motor off the flap is only good for saying the motor moves, and checking the feedback changes smoothly. Push the motor to either end of it's travel and it's almost bound to trigger a fault. The flap normally stops the motor hitting it's own stops, so the calibrated check values won't match if the flap isn't connected.

You should find a calibration funtion in your Rovacom.

Link to comment
Share on other sites

Many thanks for that David.

You are right,I failed to mention the the calibration function on Rovercom.Actually I did recalibrate after installing the new motor in the latest round and it was when the RH motor was under calibration control that it would trigger the faults described. The flap I have checked mechanically and it is smooth all the way.

However your note suggests I should try again - this time I'll make sure the fault log is clear before I start any calibration.

Given the indexing on the motor shaft/flap connection I did assume it would be roughly calibrated.


Link to comment
Share on other sites

Hevac -Calibration

I set up to calibrate the Blend motors by putting the Temp to 20*C and clearing all faults with Rovercom and turned ignition ‘off’ then ‘on’ as it appears to need, to update the HEVAC ECU.

I then found to my dismay that I had reinstalled the “faulty” motor which had started all the soul searching.I left it there!

Using Rovercom I calibrated the blendmotor/flaps.ALL OK. I then cycled the RH blend motor manually to 'Hi' and back and all is still OK!!

So what caused the original fault?

Here is my theory.During the course of faultfinding I checked continuity of all the wires in the RH Blend motor loom by inserting a probe (fine guitar wire) in the pins of the removed Hevac connector C1597 and the other multimeter probe into their connection inside the motor housing. Pin 7 of this connector gave erratic or no continuity.

I replaced it with a pin from the connector supplied with the 3 x new motors.

Pin7 is the wiper of the RH feedback “pot”……which when open circuit, Rovercom delivers :

“RH Blend motor Pot. Feedback circuit has failed.”

The reason that the circuit continued to fault when cycled to “HI”after I replaced pin7, I can only put down to my failure,pointed out by David, to have Rovercom calibrate the blend motors or I tried to calibrate while there was an active fault present.Also when forcing the motor to a position using Rovercom it certainly faulted at one or near other extreme.

Fingers crossed it will stay OK.

A/C failed to engage compressor.

This is not the first connector fault I have had around the Hevac ECU.Some time ago the A/C compressor would not engage and to cut a long story short traced fault back to needing to remove the Hevac connector CO793 where most of the in-car sensors terminate.Before removing I pushed it in and it went about 3mm further in before a solid “click”.All came right immediately and I wonder if it had been like that from new and only after some serious off-roading had moved.

Thanks again

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy