Jump to content

tail lamp woes


Michael B
 Share

Recommended Posts

The right rear turn signal on my 89 works perfectly- until I apply the brakes or switch on the headlamps. Then everything EXCEPT the indicator flashes. Also, if I apply the brakes with the headlamps on, the tail light goes out when the brake light goes on! Please help. This is my first Range Rover, so I'm new to all this. Thanks!

Link to comment
Share on other sites

B)-->

QUOTE(Michael B @ Jun 25 2006, 12:23 AM) <{POST_SNAPBACK}>

The right rear turn signal on my 89 works perfectly- until I apply the brakes or switch on the headlamps. Then everything EXCEPT the indicator flashes. Also, if I apply the brakes with the headlamps on, the tail light goes out when the brake light goes on! Please help. This is my first Range Rover, so I'm new to all this. Thanks!

There's got to be a bad earth somewhere I would have thought. Time to get the multimeter out!

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy