Jump to content

110 td5 fuel gauge still not working after new pump


Recommended Posts

Hey all my fuel gauge hasn't worked since I brought the defender but I thought I fork out and get the new pump to sort it out even though my pump worked fine (I was waiting for it to die). So I set about cutting a hole in floor and replaced the pump but still nothing on the gauge it moves a couple of mm when the ignition is switched on but nothing else and the empty light is on. Does anyone have any ideas.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy