Sign in to follow this  
Followers 0
crispyme

300 TDi single button key fob wont work

6 posts in this topic

Hi,

I have been surfing the net to try and find a solution to my problem with my Key fob

I have a 1994 300 Tdi with the single button key fob. The remote central (key fob) worked until the button on the PCB broke off the PCB. I re-soldered the button to the PCB and got the fob working again this worked for a short period of time, then the remote central locking stopped working.

Since then the remote central locking has not worked. The remote central locking works if I use the Key in the drivers door lock. But the fob doesn't do anything. I replaced the battery's in fob as this is in some discussions - no resolve. So I thought that maybe I just needed to re-program the fob to the car. So surfed again to find the re-programming sequence, did it till the LED in the car illuminates but when I press the button on the fob, the LED in the car doesn't flash. So I figured that the FOB signal is either not being sent or not being recieved.

As such I thought that I damaged the fob whilst soldering, so I bought another fob, which also doesn't work.

This leads me to believe that the signal receiver in the car central locking ECU isn't working or has failed.

Basically I havn't seen any where on the net that anyone has had a similar problem. If any one knows of a known cause of failure or resolve I would be keen to know.

Chris

Share this post


Link to post
Share on other sites

Alarm and central locking are one unit located behind or to the side of the glovebox single button fobs are user programable thats where u have to turn on the ignition and release the bonnet switch etc etc all in about 7 seconds.

When you have a look a the unit check that the antenna plug is still pushed into the socket of the unit.

And Welcome to the Forum

Share this post


Link to post
Share on other sites

I found the unit and the antenna (runs up the left side of the windscreen) seems to be connected. So I may pull the ECU out and apart to see if there is anything apparent and wrong with that.

I had the hazards constantly going off a while back when 'laning, which turned out to be the relay that flashed the indicators when the central locking activated got wet. Unplugging that for a day and re-attaching seemed to 'dry?' out the connections and resolve the problem. maybe water has gotten into the alarm/central locking ECU and caused it to fail somewhere.

any one know of anything I should look for?

Share this post


Link to post
Share on other sites

Now you have found the alarm ECU is there any indication of it being in water, if so it's it's never going to work now. With your second fob do you know if it was a working fob and did you programme it to you alarm ECU as you did the first fob.

The alarm C/L system has a inertia switch to unlock the C/L and flash the hazards if the vehicle is in a crash so this could have activated while you were off-road it has been known..

Share this post


Link to post
Share on other sites

Now you have found the alarm ECU is there any indication of it being in water, if so it's it's never going to work now. With your second fob do you know if it was a working fob and did you programme it to you alarm ECU as you did the first fob.

The alarm C/L system has a inertia switch to unlock the C/L and flash the hazards if the vehicle is in a crash so this could have activated while you were off-road it has been known..

just wondered out of intrest, where is the inertia switch for the C/L and what does it look like ?

Share this post


Link to post
Share on other sites

just wondered out of intrest, where is the inertia switch for the C/L and what does it look like ?

It's built into the PCB of the alarm/CL unit. I don't know what it would like but it would be a peizo device to detect the shock and a processor chip to iron out any false shocks fitted somewhere on the PC board.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0