Jump to content

Speedo not working


Recommended Posts

Ever since my S3 4cyl had it's gearbox replaced for a suffix "D" one, the speedo stopped working. The cable is the same as it was before the change (and it worked fine).

The speedo works (checked) and the cable spins as it should (the inner cable was even changed for a brand new one, but still no speedo).

After checking it and refitting the cable, the speedo's needle was very "wobbly" for some time (traveling a lot upwards and downwards, like it was loose) but it did manage to count 1km. But then, it stopped counting again (velocity and km).

Is there any special speedo cable to use with the suffix "D" gearboxes? What could be the problem, and what can I do to solve it? Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy