Jump to content

Odd whistly noise (Td4)...


Matt S
 Share

Recommended Posts

Hi all,

I might be being paranoid, but I'm convinced something is getting more and more whistly (if that's a word...), especially at idle. It's not as bad as, but a bit like, when you hear Tdi-engined Disco's and Defenders. I have had a poke round under the bonnet and can't identify anything specific (no change there then :blink: ) but something sounds a bit odd. Still runs fine, good mpg, not too noisy on the go - but it doesn't sound like others I've heard and is a bit noisier than when I bought it... so is it normal or is something on it's way out? Any ideas before I end up taking it to someone who will relieve me of my hard-earned cash?

It's a 2005 Td4 with 56000 miles and full service history.

Cheers

Matt

Link to comment
Share on other sites

Have you taken it toa specialist for them to have a listen. I have had a few turbo diesel cars and you can often here the turbo sppooling up, not usually anything to worry about though.

If it is louder than usual could be a PITA to sort or it could be simple. Turbo goosed... doubtful at that mileage, vacuum pipes, possible.... When was the last time it had an oil change??

Link to comment
Share on other sites

  • 3 weeks later...

Thanks for the suggestions.

In my usual way I have cured the issue by ignoring it and hoping it would go away, which it has... Put another 1000 or so miles on it and it is back to normal now. It mends itself!! Bless it...

Link to comment
Share on other sites

Hya,

The whistle on my TD4 came from the hose you can see here wiv the red arrow:

whistle.jpg

it had been cut by rubbing against the radiator ... and the air pushed out by the turbo made the whistle noise.

Hope this is also your problem coz it's not to expensive to fix ;)

cheers B)

Link to comment
Share on other sites

  • 1 month later...

Thanks for the suggestions, sorry it's taken ages to reply :rolleyes:

I checked all the hoses, no splits, then found that the clip on the hose arrowed on Jarv's reply was a bit loose - needed about 3 turns of the screw, and the noise has gone away completely. Sounds like a different vehicle!

Thanks again

Matt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy