Jump to content

Ignition Advance


Recommended Posts

Back end of September I finally got my 3.5 v8 with hotwire injection started, after the initial couple of turns f the key he would pretty much flash up straight away with a little throttle for a few minutes to keep him idling.

It was rather lumpy but Niges' maps are there to get you started and it did what it said on the tin.

Have just gotten back to it and started using megatune and I have had a few snags over the last few days.

Project was taking an age to start which was rather unusual and after talking to Nige today, he was very good to call me back, I have replaced the PWM with a new item and the beast flashed up on the button, then died.

Got him running again but he was idling at around 800 rpm and the spark advance was only 6-ish degrees.

After a few minutes letting him warm up I took the following readings whilst running at 119 degrees fahrenheit :-

idle dc was 25%, manifold air pressure was 57 degrees fahrenheit, ign advance was 5.5 degrees and the idle was 800 rpm give or take.

When I put him in gear and went to pull away the engine just died.

With the engine switched off I checked the spark advance and this told me that the engine was firing at 0.1 degrees after tdc.

Can anyone help please.


Link to comment
Share on other sites

Since I started this thread I have learnt a very valuable lesson and that when you update a wiring diagram make sure you update the version you have in your other laptop which you work from as it will prevent you feeling like an arse when talking to Nige and he points that your wiring is incorrect and he did that over the phone!!!

So, the wiring is all correct, we have plenty of new fuel, fuel is present in the cylinders, there is power to the coil packs and continuity between the edis and all 4 coils and he spins up like a good un but no bang.

I even got a mate involved to make sure that the vr sensor and gear wheel were set up correctly.

We tried getting a spark from a plug by holding it against an earth and turning the engine but got nothing however we were unsure if this would work. We tried four plugs and no spark.

Tonight I'm off to the pub with some mates.


Link to comment
Share on other sites

EDIS is very self-sufficient, if the VR sensor is correct and there is power & ground, coils wired up, you WILL get a spark (and it WILL paralyse your arm, ask Nige! So take care) even with the MS disconnected/disabled.

First thing first, double-check EDIS wiring & that it has power when cranking.

The Megasquirt won't do anything fuel-wise until it sees the tach pulses from the EDIS, so get spark sorted first!

Link to comment
Share on other sites

  • 5 months later...

so, having just gotten back into the country after 5 months away......

the vr sensor has been replaced with a serviceable item

the starter solenoid has been replaced and the engine spins

i checked for a fourth time and the ignition leads are now in their correct places


the 2 lights on the megasquirt ecu aren't lighting up when i switch on the ignition, my laptop isn't recognising the ecu and there is power to the ecu,

does this indicate an unserviceable ecu?

any thoughts are much appreciated



Link to comment
Share on other sites

Which two of the three lights?

Once is "warmup", one is "accel enrichment" and one is "squirt" or "SAW to EDIS"

So, when you turn the ignition on you'd expect maybe the "warmup" one to light if the engine is cold.

Does the fuel pump run?

How do you know there is power to the ECU if there's no lights? Where did you measure it?

As I said before, the EDIS is self-sufficient so if it's got power, ground and VR sensor it will make sparks, and if nothing else you can fire it on Easystart.

Link to comment
Share on other sites

thre are 3 lights on it?

by the mini usb connector the are 2 red lights, neither of which are lighting up.

i have placed a fuse in the supply to the ecu and there is power to and after the fuse, approx. 1.9 volts. i forgot to check the connector at the ecu itself.

the fuel pump is not working, this may be due to the fact my mate and i were doing some fault diagnosis the other day and i didn't reconnect the power supply. (how stupid do i feel now)

tomorrow i will connect up the fuel pump power supply and get back to you.

in advance thankyou for all of the sarcastic comments that i am sure will be coming my way

and as usual a big thankyou to nige


Link to comment
Share on other sites

I might be missing something here but shouldnt that voltage be full battery voltage? If it is 1.9V it isnt enough. Just to make sure that is the issue is the 1.9V is being measured from one side of the fuse to ground and not just across the fuse (one side to the other)?

Link to comment
Share on other sites

so, the jump leads turned up.

we have the engine running minus plug number 3 as i need a new lead.

we have removed plug number 7 as this pot seemed to be firing after tdc

the engine will not idle

on the laptop the ignition advance is indicating 0.5 degrees with the gear wheel at one extreme of it's adjustment and 2.5 at the other.

we are going to move the gear wheel to see if we can gain 6 degrees or so of advance for idle

we also need a new water pump but i don't think that's affecting the idle


Link to comment
Share on other sites

I may be interpreting what you wrote incorrectly - but it sounds like you are expecting physical adjustments made to the trigger wheel to be reflected on the screen?

If so, thats not how it works...

Setup the trigger wheel as per the various guides on here, then start the car and check with a strobe what you are really getting. Compare this real value to what you are getting on the laptop and then input the appropriate trim value.

After this what you see with a strobe *should* match what you see on the screen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy