Jump to content

will only run on lpg


daverangerover
 Share

Recommended Posts

runs ok on gas,wont start on petrol but tries,runs when switched over from gas,but wont rev,dies when throttle touched,screw on air flow meter has been messed with and screw on throttle body,were do you start,thought it was fuel pump, fitted new one as well as fuel line,is the meant to be 3 relays under drivers seat,there is 2 and one missing,any info really appreciated .

Link to comment
Share on other sites

OK what is it?

What age and engine?

Have a look at the "bible" in the tech archive for fault finding Efi systems.

My 1989 Efi has 3 relays under the drivers seat., one is for the fuel pump.

Can't remember what the others do, and am at least 500 miles away from being able to have a look. :)

Link to comment
Share on other sites

The three relays are:

Fuel pump (will have a white/purple wire coming out of it)

Main relay (lots of brown wires) the ECU won't work without it

Steering module - this is the red plastic one, it contains the parts they forgot to build into the ECU (no, really!) and does a few little things like keeping the fuel pump on whilst cranking. They do go faulty but the component parts inside them are pennies.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy