Jump to content

windscreen wiper problem


Goober
 Share

Recommended Posts

hi, when i switch my wipers on they dont work on the first switch, then the second switch they work but slowly. they squirt water and wipe slow when pulled back. could this be the motor thats gone? also wher abouts is it? 1987 defender

Link to comment
Share on other sites

wiper motor is located behind the dash lower left corner, remove the dash end handle 3 screws, 1 behind the LR oval badge, undo the 4 scres that hold the corner in place & you'll see the motor, could be a sticking drive rack or partly seiezed wheelboxes that the wiper arms fit on or a partly siezed motor.

Link to comment
Share on other sites

wiper motor is located behind the dash lower left corner, remove the dash end handle 3 screws, 1 behind the LR oval badge, undo the 4 scres that hold the corner in place & you'll see the motor, could be a sticking drive rack or partly seiezed wheelboxes that the wiper arms fit on or a partly siezed motor.

I located it today, how do i go about repairing it? would i have to dismantle the motor and remove if from the dash?

Link to comment
Share on other sites

I don't know this setup but from the comment earlier about wheelboxes then have a go at this.

Is there a tin lid affair on the top of the wiper assembly?

If so then you can take it off and release the drive cable from the gearbox. With the wipers pulled back from the glass can you push and pull the drive cable and make the wipers turn.

If you can then that part of the mechanism is good. If it is very stiff then that may be your problem and is not easy to get at.

Take the wiper mechanism off and take it to the bench to strip down. It probably needs a good clean and fresh grease but you should also check and clean the commutator and brushes.

Steve

Link to comment
Share on other sites

My 1990 110 the wiper's only worked on fast and it was the stork at fault it was about £40 for a new one.

having said that intermittent still doesn't work

Il have a look tomorrow and see if find anything when i strip it down. dont all functions have to work for the mot?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy