Jump to content

Rough running V8


knacker
 Share

Recommended Posts

Hi everyone,

I have just acuired a 95 3.9 V8 Disco and it's running a bit lumpy on the hand right side of the engine (as u look from the front of the truck), Have changed plugs and leads but have noticed that the cat on the on the same side is glowing red hot after running for a few minutes. Is this what could be causing the problem ?

Link to comment
Share on other sites

Job sorted, Someone had put the leads on wrong on a couple of leads !! Had another look today and checked the leads were right, When we put the new ones on we just changed like for like and didn't think that they could be on wrong in the first place. It runs sweeeeet now :D:D:D not bad consiering that we got it cheap because it was running like a bag of nails B) B) B)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy