Jump to content

P38 EAS problem syncing with software


RRMatador
 Share

Recommended Posts

Hi everyone, i'm having trouble with my EAS, its been an ongoing issue for me for some time now. I'll shortly be losing my marbles and im hoping that the expertise on this forum will prevent this. Here are some details on my saga....

It's a 1997 2.5DSE

Had random height adjustments being made when not called upon, ie kept raising to high mode and also intermittent pump running in short bursts.

To eliminate a leaking block, I have rebuilt the valve block with new seals throughout. I couldnt see any evidence of failed old seals when rebuilding, all the rubber O rings were supple and well shaped, and the diaphragm seemed ok too.

The original air pump I have rebuilt countless times, new piston, barrel and seals, new thermal switch, new electrical bushes - however after a couple of recent very long journeys, it finally gave up. Starting the car for my return journey home it failed to reach normal ride height, ran just long enough to inflate pillows enough to keep it off the bump stops and to avoid a hard fault I pulled fuse 44 to disable it, as I couldnt face a bone shattering journey back.

So I've shelved the old pump and brought a brand new unit, it's not OEM but a Dunlop replacement.

After fitting said pump, it ran for a short period before the car rose to normal ride height.

However, pump was still running in intermittent bursts, on for roughly 15 secs then stopping then back on etc - So I was now thinking that I've either got a faulty pressure switch or faulty driver pack. If i let the pump run in these cycles it does fill the tank, and I can raise and lower the car a few times in quick succession. It also seems to hold its air well, I'm confident there are no leaks, either between the tank and the block and also the block to the pillows.

At this point, I thought i'd plug the laptop in and run the EAS software to see if there was any fault codes - something that I have done countless times. However I cannot get the software to Sync this time. I've usually used comm port 4, but this was not working. I cycled through the others and for some reason using comm port 3 was allowing me in (checking my laptop hardware serial ports when cable was attached was giving me both 3 and 4 ports as an option??) When I click initialise it starts the cycle connection but I never obtain a good idle. It flashes green periodically - briefly. I plugged the original air pump back in to see if the new "aftermarket" dunlop pump might be throwing an issue, but got same result. I've tried using a different laptop running a different version of Windows both 7 and 10. Nothing...

I've again pulled fuse 44 to disable the system as I do not want to damage my new pump with intermittent running for extended periods. My worry is, if it throws a hard fault I currently cant access the system to reset it.

So my question is, can a faulty driver pack be preventing me from making a connection with the EAS software? I've checked the cabling and the wires all seem to be ok. Could I be unlucky enough to be suffering from a faulty EAS ECU, and have an issue with either the pressure switch and or the driver pack? I've been chucking money at this car left right and centre recently, trying to sort out other "electrical" faults, I just cant keep shelling out for new parts that dont cure the problems. Living outside the uk, my access to 2nd hand parts is limited and fleabay sellers now seem to want excessive amounts to post items abroad.

Please, any help or thoughts would be greatly appreciated

TIA Matt

Link to comment
Share on other sites

Where do you live? There might be someone with P38 expertise near you.

Bad communication could be the ECU, but could also be corrosion in the wiring for the OBD plug. That usually happens in the outer kick panel in front of the RHS door.

Driver block sounds plausible, although I haven't had one fail myself so don't know the symptoms.

The pressure switch should be easily testable, see the attached picture.

post-18506-0-23440700-1461735193_thumb.png

Link to comment
Share on other sites

Im living in southern Spain, deep in the countryside.

I've removed the kick panel in passenger footwell and checked the wiring - all seems to be ok. Its RHD as i bought the car over with me, but it's been here a decade and due to the severe lack of rain we have here wire corrosion generally isnt a concern - it's the dust that is generally the culprit. I havent suffered from any leaks from the heater matrix and pipework that would effect the wiring. I'll double check again and go back over everything to see if i've missed something, which is unlikely. I'll give everything another blast with compressed air to blow out any dust that maybe still lingering within the connections.

Many thanks for the wiring diagram to test the pressure switch, I shall give that a go. My main concern at the moment is not being able to sync the software as this would stop me from resetting the system and clearing any stored faults.

I've done a fair bit of homework going through various forums and threads, and having done so I was aware that generally the problem has been associated with corroded wires, but having not found any evidence of this in my loom I was left scratching my head, which is why I'm asking for help, hoping that some one might have suffered from the same problem....as so many of us Landy owners do.

Thanks again

Matt

Link to comment
Share on other sites

I say this a lot on Landie forums: check every earthing point you can find. A bad earth can play absolute havoc with these cars. You'll need to take each one apart, clean, and put some dialectric goop on.

Link to comment
Share on other sites

Earth points are important indeed.

If the system does go into error, you can just unplug the relay under the driver's seat (with some practice even while driving :P) and the ECU will be turned off but the system will not deflate the bags.

Are you using a straight serial connection, or a USB adapter? If so, which adapter?

Link to comment
Share on other sites

I'll check the Earth points this weekend when I plan to dedicate some more time to finding the fix.

I'm using a straight serial connection. Never been a fan of "adapters" - just something else it misplace or to become faulty.

Thanks again chaps - i'll keep you posted when I've found the fix

Link to comment
Share on other sites

  • 2 weeks later...

PROBLEM SOLVED. After removing the ecu's (both EAS and transmission) and giving all the connectors both inside the plugs and the terminals in the sockets a good cleaning with electrical cleaning agent and cleaning any other connectors within the system the problem has gone. Connected straight up to the laptop. Intermittent EAS pump running has also gone away. System is now running correctly. I'm assuming the culprit was dirty/bad connection in the main ecu plug.

Thank you for the advice - and the motivation to recheck everything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy