Jump to content

P38 2.5 Down on Power


Shane Ward P38 2.5
 Share

Recommended Posts

hi guys,

My p38 2.5 is nor running to well at the moment. firstly it has that hot start issue but secondly its just started to be really down on power. When i floor it, it kinda stops around 3000rpm and is very very slow to move past it. Only just bought this a few weeks ago and seemed fine but today all of a sudden its started this. Seems to run a little better when cold but couldnt be that sure. any ideas. Im doing a full service on it at the weekend including Diesel Filter just incase its blocked etc but can you think of anything else that could limit the rpms and make it run quite bad.

Cheers

Link to comment
Share on other sites

The injection pump timing (which is an absolute *beep* to set) could be off, I've seen it happen due to normal wear. Good idea to replace all those gaskets while you're in there. General procedure (as per BMW) is: hit it with a hammer until it runs well :rolleyes:

Link to comment
Share on other sites

... can you think of anything else that could limit the rpms and make it run quite bad.

One of the flexible pipes in the intake system has come loose (turbo outlet to intercooler, or intercooler to inlet manifold).

Or the pipe between the intercooler and the inlet manifold has delaminated, with part of it dropping into the centre and restricting airflow. When this happens the loose flap goes back into place when the engine is switched off, so it can be difficult to spot.

Alternatively, check the small diameter rubber pipe (with braided cotton cover) that goes from the inlet manifold to the boost pressure sensor fastened to the fuel filter assembly.

Link to comment
Share on other sites

Yep. There's also a triangle-head bolt on that thing, which apparently they don't have an official tool for, so you just take a cheap 7mm socket and hammer it on...

Once you've done it a few times it's pretty easy (apart from that one bolt, that is), and getting it set up correctly is just a matter of trial and error (start -> no good? -> hammer -> repeat).

Link to comment
Share on other sites

Changed, all the filters, driving much better but still down on power. Its seems to happen only when i put the foot to the floor and it will rev up to 5000 , but then it kinda goes into limp mode, 3000 rpm , like it over boosted or something if that makes sence.

Im taking the intercooler off tomorrow to clean it out. My model 1997 2.5 chassis number is SAllPAMW3WA377253 doesnt seem to have a MAF sensor or EGR valve.

Also took top intercooler hose off and was quite a bit of oil in it, maybe this is normal enough but ill clean it out either way. Does any know if i need to remove the rad aswell or can i unbolt the front grill and remove it that way.

Any think else it might be if its not the pipes/intercooler.

Might get someone to look at the diesel pump, its hard to start when hot, so might kill two birds and get the fuel pump advanced it that what i need to do???

Cheers

Link to comment
Share on other sites

  • 2 weeks later...

Changed, all the filters, driving much better but still down on power. Its seems to happen only when i put the foot to the floor and it will rev up to 5000 , but then it kinda goes into limp mode, 3000 rpm , like it over boosted or something if that makes sence.

Im taking the intercooler off tomorrow to clean it out. My model 1997 2.5 chassis number is SAllPAMW3WA377253 doesnt seem to have a MAF sensor or EGR valve.

Also took top intercooler hose off and was quite a bit of oil in it, maybe this is normal enough but ill clean it out either way. Does any know if i need to remove the rad aswell or can i unbolt the front grill and remove it that way.

Any think else it might be if its not the pipes/intercooler.

Might get someone to look at the diesel pump, its hard to start when hot, so might kill two birds and get the fuel pump advanced it that what i need to do???

Cheers

Hi Shane,

Hard start when hot is a typical sign of an aging injection pump on the M51. Easy test is to run the engine till hot and then cool the pump with a garden hose (maybe wait a couple of weeks for warmer weather before turning your drive into an ice rink :-) ). Should start easily then. Do check the intercooler to intake manifold pipe very carefully as mentioned above. The delamination is not easy to see at times.

I'll also add to your thread on chipping this motor here: chipping the DSE makes it a real pleasure to drive. The weakest point of this motor tho is the cyl head. The additional thermal stress placed on the head due to chipping/playing with the boost will cause cracks in the head - usually between the exh valve seat and the pre-chambers. IMO still a very worthwhile mod, tho. I regard cyl heads on my DSE as a 100k service item...

cheers

steve

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy