Jump to content

3.9 EFI won't prime fuel pump


Recommended Posts


I have a Land Rover 101 with a RR 3.9 EFi in it (not my conversion, it's the way i got it) so I'm posting this question here as it's an engine issue I'm experiencing.

The vehicle ran fine a week ago when I parked it up and went out today to use it and it won't start.  It spins over nicely so first I checked i'm getting spark by holding the HT coil lead to ground (nice spark) and put a plug tester into one of the plug leads (nice bright light).  A squirt of easy start will let it run for a second or two so I assume the ignition is OK and therefore it's a fuel issue.  Previously you could hear the pump prime for a few seconds when the ignition was turned on and now I don't hear that.  The pump works fine when I hook up a +12v to it, but when the  I try to start it with this +12v  connected it still won't run, so something is telling the engine that it shouldn't go.  Just to confuse matters after a bit of prodding and poking it did run again, so I let it run while I started packing up my tools and then after a minute or two the engine stalled / died and hasn't started since.

I'm wondering what simple diagnostic steps I can take to get this sorted, or at least get a little closer to finding the problem.  My main issue is that this is a non-standard engine for this vehicle and has been DIY installed and hence any wiring diagrams may not reflect reality!

Thanks all

Steve H

Link to comment
Share on other sites

First question is did you buy the 101 down south from a chap called Martin?

To the problem at hand - if the pump runs with 12v on it then hopefully it's OK (although rarely they can go weak yet still run), so I'd check if power is getting through to it and if not, where it stops.

1st stop is to check you're getting power on the brown wire into the fuel pump relay.

After that, you can jumper out the fuel pump relay to prove it - jumper the brown wire to the white/purple to run the pump permanently (while chasing the fault), and you can check for 12v / gnd out of the ECU across the white/slate and blue/purple pair, there should be 12v across this when the ECU wants to run the pump (I can't remember if it switches the 12v side or the ground side, so be careful how you measure to avoid fooling yourself!).

I've had the relays fail and you need to be aware that they're an odd type - 5-terminal with two ganged terminals, confusingly marked 87 and 87a even though that disagrees with how VWP list them;

R30BT- 5 blade twin make & break. Similar to R20BC, but with two blades at 87 feed.



Here's the 3.9 V8 system diagram for you, hopefully it's just been transplanted over to your 101:



Link to comment
Share on other sites

Thanks.  I'm pretty sure the pump is ok and to my mind the main symptom here is it's not running when I turn the ignition on whereas it always used to.

My tests this morning have narrowed it down to what I think is the ECU - it'd be good if you could confirm my diagnosis.  With the ignition on I'm not getting 12v on the 87 terminals on either the main relay or fuel pump relay (unlikely both relays failed at the same time).  I then confirmed the ECU is getting 12v on the correct connectors when ignition is off and on.  With the ECU connector removed I grounded the 'switch' terminal on the main relay and did then get 12v on the 87 terminal.  This to my mind means the ECU is not switching on the relays?

In addition I hooked up my laptop with RoverGauge to the ECU and it said it couldn't communicate with the ECU (it worked last time I used it).



P.S The 101 came from a guy called Dave in Bristol!  

Link to comment
Share on other sites

Good point, I'll double check the earth tomorrow.  It looks like Pin 4 on the diagram above (and mine here) and yes I've been working through the troubleshooting manual.

I've been looking on eBay for second hand ECUs and there seems to be a myriad of different part numbers for the 14CUX - does it really matter which I use in this case (mine is PRC9061/80274B) or are they pretty interchangeable?  i.e choose a RR / Disco 3.9 from the same year (ish) and it should be OK?

Thanks for the help.

Edited by hallio
Link to comment
Share on other sites

There's quite a few earths come out of the plug, bear in mind all the current for the fuel injectors etc. is grounded though the ECU even though the 12v side is supplied through the external relay.

I doubt the ECU is faulty, they're not really prone to failure - most faults are wiring or a sensor or such like.


Also, it would be remiss of me to get this far down an EFi trouble thread without suggesting you fit Megasquirt in its place :D

Link to comment
Share on other sites

On 11/1/2019 at 3:03 PM, hallio said:

The pump works fine when I hook up a +12v to it, but when the  I try to start it with this +12v  connected it still won't run, so something is telling the engine that it shouldn't go.  Just to confuse matters after a bit of prodding and poking it did run again, so I let it run while I started packing up my tools and then after a minute or two the engine stalled / died and hasn't started since.

This was the bit that suggested to me that the pump was on its last legs.

all the other suggestions are good of course ;)

Link to comment
Share on other sites

Thanks.  I have a spare pump so may just drop that in for the purposes of elimination.

My thinking it was the ECU was because both main and pump relay don't switch on when connected to the ECU (but do seem to be working) and in addition my RoverGauge can't read from the ECU when previously it could?

I'll go over all the earths though and cleanup all the relay contacts etc though next, seems a sensible move.

TBH MegaSquirt probably isn't really worth the effort - I barely do any miles in this vehicle and it's cost me enough to get it this far!  I thought all my problems were over when I parked it up a week or to ago after spending most of this year getting it up and running again!  (I should know better than that with old Land Rovers).


Link to comment
Share on other sites

The ECU may not switch the pump on until it decides it needs to - usually that's once it sees some pulses from the coil -ve although I don't know if the hotwire system primes the pump? If you're certain it WAS doing it before and isn't now, by all means suspect the ECU... but if you're not sure, I'd wager it's just not choosing to run it until it needs it.

As Bowie says, could be a weak pump or could be the fuel pressure regulator has given up the ghost.

Link to comment
Share on other sites

After more digging it looks like it may be the main ECU relays on the blink - the fuel pump relay is actually OK, however I suspect nothing will work if that main relay isn't working.

Certainly an easier (cheaper!) thing to try before the ECU anyway 🙂 

Thanks all.


  • Like 1
Link to comment
Share on other sites

  • 3 years later...

Anyone  help me decide , i m having this issue  , intermittently , i have a volt guage on the fuel pump and it supposed to prime on ignition ( 2s)  and then wait till engine on , signal then rerun to fuel pump again  again .( theres a lift and high pressure pump , its the HP prump Im refering to .


Walked 10 km  yesterday and  had to be towed !!!!


I have had in past  lost fuel pump voltage and  then she cuts out  after starting ok, i used to have a separate battery ion cab ready to power the fuel pump  directly .

Would a main and fuel pump relay  be a good idea to rule  them out.

I had a meter on them and wasnt seeing  voltages to them  last night  so i didnt expect them to work


battery to ecu-inertia sensor ( if i can find one) to relay to injector fuel pump.

Pu,p  seems ok on bench and when it has power she dives  fine.


Yesterday as i braked hard and did a swerve to avoid a cyclist  the fuel voltage disappeared , i can no longer get it started.


Can anyone confirm  ( transplanted into a 199 series 2 , 3.9 efi)  where i might find an inertia  sensor  which on diagram is there to cut fuel in case of  accident i gues >?



Link to comment
Share on other sites


Without knowing what has been done with your particular conversion it's hard to be certain what the fault could be - bearing in mind the ECU will switch the fuel pump OFF if it thinks the engine has stopped (not seeing pulses from the coil -ve and not seeing airflow on the AFM) so bear that in mind - it's easy enough to see if the ECU is powering the relay or not with a simple LED wired to the ECU-side of the relay.

As a start I would try following the fuel pump wiring from the fuel pump itself through the loom, relay, and into the ECU pin to see if there's anything obvious.

Fundamentally you've only got a few things that can fail;

  • Wiring harness (EG a bad joint or broken wire)
  • Relay and power feed to it
  • Signal from ECU
Link to comment
Share on other sites

Thanks to both for help , last night i proved both relays are  clicking and passing power from term 30 to outputs 87 and 87 on bench  , so Im back before relay in the hunt again  where im not seeing voltages  i used to , lift pump humms away  , ignition  light  etc fine , so some  things are getting power ,  its pull harness out where i can and   walk my way back to the ECU.ECU is v acessible but its like like going to a funeral and unable to look at the body , i fell added sadness will  come over me once i  look at ECU & accept the fact its never comming back ,   maybe  the ECU is the root tormenting me all along but the intermittent nature is wierd - dry joint inside ECU didnt like the bump ??.

I have a feeling  'never smart with old vehicles'  that  some thing is loose , like as if the earth that the fuel pump looses its  grounding .

i did find an earth looking wire ( conversion person used some home earth wires colour coding  in a loom headed to ward he altenator - i hear you all sighning and turning the page now)  


So before i  go looking for a loaner ECU anyone know where the  main earths that the ECU/fuel pump high press ure  might join the chassis as this might be loose and explain the loss of 12v to the fuel pump   while driving along.IT wont stadt now as its   still missing  voltage , i apply manual 12v and that no longer ools it .



Link to comment
Share on other sites

So you say the relays click and deliver 12v where they should - does that mean they click if you test them but the ECU is not engaging them, or does that mean the ECU engages them & they click but stuff still doesn't work?

A few photos of the main points of your wiring loom & fuel pump setup might help give us a few clues.

Also highly unlikely the ECU has gone faulty, far more likely bad wiring or a dodgy sensor/signal - always look at the cheap & easy stuff first!

On the 3.9 the ignition amplifier on the dizzy like to fail for a pastime - that would stop everything.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy