Jump to content

lt77 problem getting reverse


jericho
 Share

Recommended Posts

med_gallery_1618_185_295022.jpg

My newly installed defender style lt77 is reluctant to select reverse.

The little spring loaded plunger next to the gear lever with a ball bearing thingy is jamming up.Took it apart to clean it,that didn't help,but the ball looked slighty non-round.

Should I replace the ball,or the whole unit?

What is this part called?

Any suggestions? Thanks.

Link to comment
Share on other sites

thats the detent housing, the ball bearing is available seperatly part number is 571146, does it engage reverse with that part off the vehicle, if not it could be a badly adjusted reverse light switch causing the problem.

Yes,it works with that part removed.

Top info. Thanks very much.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy