Jump to content

Engine Disabled :(


Recommended Posts

Posted this on Land Rover Net and have had no response all day.

Last night at work the key fob worked. Then it stopped so I tried to remove the battery cover to change the battery. While trying to remove it the notch for the penny/screwdriver etc shredded leaving a round recess in the cover. This meant I couldn't remove the cover. Went out the car again and could only unlock the drivers door, the others wouldn't even open when I pulled the internal locks up. I put the key in the ignition and got "Engine disabled Press key". Now, I can't do this as the key doesn't work.

I went home and searched the handbook folder for the EKA code we used last time this happened, went back to work, entered the code and I could start the car although the the remote still didn't work.

This morning I have the same message on the dash but I can still unlock all the locks from the drivers door manually.

I've been to my local LR dealer to buy replacement button cover, battery cover and batteries. They said once I put the new batteries in and try the EKA code again I will be able to start the car. This isn't the case and I still can't start the car.

Can anyone help?

Link to comment
Share on other sites

Which version of Range Rover are we talking about? It's got to be a P38a or later to have messages on the dash.

If you don't get a response on here or one of the other forums, try digging around on www.rangerovers.net to see if it's a known issue. Unfortunately, if the key sequences aren't working I'd guess it's going to mean a visit to a garage to get it done with a diagnostic computer - hopefully David Sparkes or someone else how knows a bit about the later Range Rovers will be along in a bit to point you in the right direction.

Link to comment
Share on other sites

I certainly missed this the first time around, on 6th Dec.

As we have got to 11th Dec and there has been no follow-up by David Stanley there seems little point in progressing now, he's probably catagorised LR4x4 with Land Rover Net :-))

As geoff surmised, I'd also guess 38A, although I know nothing about the L322, and without more involvement by the owner I'm not going to bother reading it up.

I note on day 1 he started the engine once he had got the EKA, but on Day xx after changing the fob batteries he could not start the engine.

Not being able to remotely unlock the car after changing fob batteries is a straightforward loss of synchronisation, but re-synchronisation can only be done AFTER the car is unlocked with the EKA (security therefore switched off by the EKA process).

I note on Day 1 he could also not unlock the other doors by manually lifting the sill button in the drivers door. This may be because the security system wasn't disabled (remote faulty, EKA not known).

Shrug. Perhaps he found Rangerovers.net himself, although I don't recall seeing a David Stanley post.

Link to comment
Share on other sites

"A friend has suggested disconnecting the battery for a while for the ECU to reset, will this achieve anything?"

Not much, although you will learn how to 'set' all 4 windows, the sunshine roof (if fitted), and the Radio Security Code!! It is a common suggestion, just that it doesn't achieve much.

Now we know you are watching, where are you with this problem?

I surmise the remote does not work, in that it doesn't unlock the car. Presumably the new batteries went in correctly, and the fob red light flashes when you press the unlock button.

I also surmise that the EKA does not allow you to start the engine.

Quoting the Model Year is good, as it confirms you have a friendly re-synchronisation coil on your car, which should do as it says, and recognise the key fob after you insert it in the steering lock.

Is there anything else not working on the car, before or after this incident?


Link to comment
Share on other sites

I've had the battery off a few times after it's gone dead (it has spent a fair bit of time sitting over the last year) and never had to enter the radio code but I'm familiar with re-syncing the windows lol.

Everything worked before although there has been "alarm fault" showing since the battery went dead earlier in the year but the alarm does work (I've heard it with my head under the bonnet - ouch) and the front and rear passenger side window switches can be a bit hit and miss.

The batteries went in correctly but the red LED does not flash when a button is pressed, but this stopped happening before I changed the batteries and prompted me to change them thinking they were dead.

I've just read an extra bit of info saying to turn the key to the left 4 times before entering the EKA so I'm going to try that although I'm sure I didn't do it the night it stopped the first time.

The 5 button presses near the car didn't do anything.

Link to comment
Share on other sites

I'm no expert but if the LED ain't flashing that suggests the remote isn't working. Without seeing it this could be a daft question but are you sure the battery(ies) are in properly, not touching any metal parts they shouldn't be, and that the contacts are good?

LED's don't generally burn out so if it's not flashing I'd suspect something up with the fob.

Link to comment
Share on other sites

Turning the key four times to the left first and then entering the code has allowed me to start the engine at last, I bet that was in the manual - can't wait for the new one to arrive.

Just had the batteries out to check they were in correctly and they are. The positive side of the battery is facing the back of the battery cover with the + on it and all the contacts are clean and contacting. Guess I just need a new fob now, over £100 from LR right?

Thanks for the help, still had no replies on landrovernet.com

Link to comment
Share on other sites


I forgot to say, but I didn't expect the 5 button presses to do anything. The Freelander is a later design than the 38A and design moves on.

The lack of fob red light flash is significant, as it indicates electrical failure of the fob. You need to visually examine the fob closely for any 'obvious' reason why the batteries aren't powering the fob. Then you need to get even closer, possibly with a magnifying glass, or £1 spectacles about twice the strength you normally wear (so +2 if you don't wear any, +4 if you wear +1.5 / +2 normally, etc). You are looking for dry / cracked joints on the printed circuit.

If this isn't your area then look for someone who builds electronic kits as a hobby.

The alternative is a new fob, only from the Dealer, NEVER from ebay. Expect to pay in excess of £100.00.

You have never mentioned a second fob, so I assume you don't have one. If you have memory seats you need Key 1 or Key 2. Buying a second remote means you need to know which you have, but if the new remote will be your only one, just buy a Key 1. Note that the Dealer (or you) should be able to swap your existing blade onto a new remote. With the blade held halfway towards open, look for a little roll pin holding the blade to the metal hinged section.

EKA works by a microswitch in the latch telling the BECM what you are doing with the key.

The next point is important, as it confirms the microswitch is working AND that you are turning the key correctly.

At each turn of the key to the lock or unlock position, the side lamps warning lamp in the instrument pack will flash to indicate that the key turn has been recognised.

Note this can be difficult to see, especially in daylight. If you are having difficulty, open the door, ignition on, wind the window fully down, ignition off, close the door, and start the EKA. Now, because you are not looking obliquely through slightly tinted glass, you will see the warning light more clearly.

Now do the EKA thing, which is detailed in your Owners manual. At this point I have the Manual in one hand and the key in the other. There is nothing wrong in reading instructions.

Note the step 4 alternatives

EKA procedure - Vehicles up to 96MY

1. Unlock driver’s door with the key.

2. Open the door and the alarm sounder will sound twice.

If the key is inserted in the ignition at this point and an attempt is made to start the engine, the engine will not crank and the message centre will display ’ENGINE DISABLED PRESS REMOTE OR USE KEY CODE’.

3. Close the driver’s door and ensure that all doors, tail door and bonnet are closed.

4. Up to 96MY: Turn the key to the lock position.

From 96MY: The key must be turned four times to the lock position.

I won't bother copying the rest of the instructions here.

Note that with a faulty fob you will ALWAYS have to use the EKA, as the fob will never synchronise to the car.


Link to comment
Share on other sites

'Alarm Fault' without any other message is normally the ultrasonic sensor, at the top of the passenger side B pillar. Just pull it out of the trim and inspect for dead spiders etc. Disconnect and reconnect, then replace. It takes about 5 fails before it flags a fault, so you have a bit of leeway before it faults again to confirm you need a new one. If you have some local, try a scrapyard for Rover 214s or similar for the same sensor, possibly in different colours.


Link to comment
Share on other sites

"Turning the key four times to the left first and then entering the code has allowed me to start the engine at last, I bet that was in the manual - can't wait for the new one to arrive."

I'd gathered from your 1st post that you had the Owners Handbook. You can download the complete Workshop, Electrical, and Owners manuals on a RAVE CD from the Green Oval site. You want CD 2, but note the file size, and the conversion you need to do.


"Just had the batteries out to check they were in correctly and they are. The positive side of the battery is facing the back of the battery cover with the + on it and all the contacts are clean and contacting."

Yes, your batteries are orientated correctly, again it's something in the Owners Handbook.


Link to comment
Share on other sites

Note that with a faulty fob you will ALWAYS have to use the EKA, as the fob will never synchronise to the car.


Glad you mentioned that as I've been out in the car most of the day today and each time I go to get back in the car I have to re-enter the code. I guess that confirms the faulty fob and I have a direction to go in to get it fixed.

I can get a friend at Uni to inspect the circuitry as he's on an electronics course.

I'll also have a look at the sensor on top of the door pillar.

I have the handbook folder but it only has service history and receipts etc in it. The previous owner didn't have the instruction manual.

Thanks a lot, you've all been very helpful on this forum. Doubt I'll go back to landrovernet.com :D

Link to comment
Share on other sites

Got the fob working again, went round my mates house and he got it working again. He wants to explain what he did so that if anybody else gets the problem they can use this help and save themselves over £100!

Basically all I did was push the pins that connect the negative side of the batteries up to make sure they are contacting and then i made sure that the positive side is connected. This was the tricky bit cause the positive side has a metal strip running down the seperate battery cover and was ment to touch a little bit of metal that is in the main casing but this peice of metal was twisted and bent to the side so I used what tools I had(biggest pair of pliers possible according to dave) to bend this strip of metal to the centre of the space for the battery cover and it worked....a simple bit of non-connection was all the problem was.

Link to comment
Share on other sites

If its any help to anyone,as entering an EKA code seems to be more difficult than scaling Everest to most owners.When entering the code all panels inc bonnet/tailgate must be shut.When you turn the key in the lock it helps to have the drivers window open so you can observe the green light twixt rev counter and speedo that comes on with the lights.This must come on with each turn of the key or the process will fail.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy