Jump to content

P38 air suspension technical problem - long post


Recommended Posts

I wonder if you can help with a problem P38a I am having – I just need some ideas!

I have a small Land Rover workshop in Canada and I mainly do Defenders and Discovery diesels, but I seem to get lumbered with Freelander’s and P38’s which I have little interest in!

So on a tow truck a few weeks back, came in a nice looking P38a sat on the bump stops – this has been passed from pillar to post as no one wants to know so finally I said I would sort it out

It arrived with a refurbished valve block and pump from Land Rover ($1700 fitted!) 4 new standard air springs and correctly fitted

But it will not lift

When I first got the car the pump was not working, so I did the usual checks on the fuse box, relays etc – all was working but there was a hack on to the green feed wire for the pump to make it work without the ECU input.

So I checked all the wires and although messy and full of holes from others prodding and poking with test meters, it seems to be fine. There is continuity on all wires to the EAS box under the dash

I have the Britpart Lynx diagnostic system which is made by Omitec the makers of the test book so I can read all codes and operate the valves and check the heights etc.

The ECU shows no codes at all and I can communicate with it.

I cannot operate the valve block with the Lynx nor will the P38 ECU so I checked all the valves by hand using a 12v test lead and all make a nice click – and by blowing compressed air the valve block is working – but only if operated by hand and a few wires.

So the only logical think I could think of was the Driver pack was shot = so I got an OEM unit from Allmakes – when fitted the pump was working fine – but pumping like there was a blockage – so I checked all the lines and the dryer – all good. Seems like the inlet is not opening.

I noticed even though the Lynx was showing status of the ECU showing rear valves / input open and front closed (normal for an empty system) the valves were not clicking - I even got a buddy of mine to listen to be sure

So as last resort I followed Falconworks suggestion of the following:

For P38a, below the LH front seat are two stacked ECUs. The lower one is the EAS ECU (control module). On the left hand side is the system relay (small black box). For Classic the components are under the RHF seat. Disconnect the relay. Gently un-latch the 35-pin connector on the front and swing it out and off its hook. Remove the forward cover from the connector so you can see the pin numbers molded into the side of the connector: it slides off endwise and requires no force. Collect the two loose insets - do not misplace them, you can't order new ones. The pin numbers are molded into the back of the connector.

1. PIN #1 is hot

2. PIN #8 goes off to power the pump relay. The system overpressure switch sends its information to the ECU: when you run the pump without an ECU connected you have NO OVERPRESSURE PROTECTION. Only connect this pin to power when you know you need more air.

3. PIN #9 is the exhaust solenoid. When powered it lets air out of whichever spring's solenoid is also powered.

4. PIN #26 is the inlet solenoid. Similarly it lets air into whichever spring's solenoid is also powered.

The springs' pins are:

1. LHF #10

2. RHF #27

3. LHR #11

4. RHR #28

To go up fit jumper to pins #1, #8, #26 and one of the springs. Refit the relay. Remove the relay when done. Rewire for the next spring and repeat the process.

To go down fit the jumper to pins #1, #9, and one of the springs. Refit the relay. Remove the relay when done. Etc

So still nothing not a click from the valves – but now I am worried I may have blown the Driver unit by feeding it 12 volts not a computer signal

So you have any idea why the car is saying it is doing something, but no result?

I have a feeling the ECU is defective, but I have nothing to substitute - which is making life hard – I have a feeling the ECU is like flicking a light switch and saying yeah I really have the switch on – but the bulb has gone – so no ECU faults as it cannot detect them

Does anyone have any ideas what this could be?

I have worked on these trucks before and the EAS was pretty easy to fix with common faults - but this is a nightmare as I do not know what others may have done – and I have no known used working parts to substitute

Logic says it should work, in practice not!

Link to comment
Share on other sites

Wow, you certainly have been busy trying to diagnose this one!

I am not an expert by any means in the air suspension setup, but if the valve block all operates, the pump and reservoir are functional, and the wiring fuses and relays all all testing positive, then it can only be the ecu can't it?

Over here it would be very simple to just obtain a second hand ecu from a P38 that is being scrapped and swap it in. There are usually loads on eBay. Would someone post one out to Canada for you maybe? There is one I have just found from who will post worldwide, and its £28.00 plus postage. item number 321122864946 for instance. Obviously you would ideally need to match the correct part number.

Link to comment
Share on other sites

Two things, you haven't mentioned the pumps overheat protection, the switch is buried within the pump, and the last time I was working on this system the parts were available via the aftermarket. The switch fails open, when it cools it should close to complete the circuit, but while it works sometimes, when it stops working, that's it. Be aware the switch is part of the operate circuit of the control relay that switches the heavily inductive load of the pump. The switch does not directly control the pump.

Writing this, I now seem to recall that some people have fitted external thermal switches.

The second thing, and probably the most help if you are going to be 'forced' to work on 38As, you should also be locked into RangeRovers.net, particularly their Forum, but don't overlook their repair information pages on the EAS

As I've been out of the circle for some time it took some finding, but it appears the Forum is now run under the AutoGuide.com umbrella, but the link above is direct to the Forum.

There WAS a US based firm called Rover Renovations, the EAS system was one of their specialisms, but Rover-Renovations.com now hits a firm in Essex UK, of which I have seems unrelated to the firm I recall.


Link to comment
Share on other sites

As I mentioned Rover Renovations in the USA I thought I'd better pass on the information I've found, albeit that it's now old hat.

The Rover Renovations firm in the USA closed down, after apparently losing touch with Customers and reality.

www.socalusedroverparts.com now meet the same market need, but as this thread explains, is not, nor ever has been, an associated company to the USA Rover Renovations.

I have noted that some of the links embedded in articles on the RangeRover.net site lead readers to the UK based Rover-Renovations site.


Link to comment
Share on other sites

Thanks for the replies

I am leaning towards the ECU and will have an attack on Monday to see if it is putting a signal out - I was told the ECU puts out a 12 volt signal to the driver block which then converts it to a PWM signal to operate the valves and it is not good practice to put 12 volt direct to the valves. I would have thought it was the other way round but it is a Land Rover after all!

I know it is not the pump as it is working on its own with no trick wiring and I have spent more time reading about this than working on the car - just wondering if someone has had similar problems

With the doors closed and the engine running the pump runs and dash lights are normal - it is on low and the STD heigh light is blinking

The pump is working hard as the inlet is not opening = the Lynx unit shows the inlet and rear valves open (as it should) but nothing happens

it is the most illogical car I have worked on - no wonder other garages back heeled it!

I used to have one of these cars years ago and it was good for swapping parts over to fault find - I know what these cars are like and it is so easy to swap a defective part for one that is defective and thus go round in circles!

Link to comment
Share on other sites

Are you getting pressurised air into the reserve tank?

I think the point you are making about the Lynx is common to most testers (system monitors / interrogators). What they tell you is that a signal has been sent (normally a voltage) to open the valve. They ASSUME the valve has opened, but there is no device to say the valve has moved, the only indication the valve is open is that the passage of air is having an effect (inflating the spring), which is obviously not happening.

I take it as read that you have removed the pipe from the valve block to the spring, and found no air issuing from the port.

You say "It arrived with a refurbished valve block and pump from Land Rover ($1700 fitted!)", but I think you have to assume you are going to have to dive into valve block itself to check for physically stuck valves. There should be three valves clicking at least, Inlet, front left and front right. I'm more inclined to think a common fault is they are all stuck through lack of use, rather than all suffered an electrical fault.

Overhaul instructions were on the Rover Renovations USA site, and may be buried within the RangeRovers.net site, but you might also ask www.socalusedroverparts.com as he appears to now sell the parts.

You say you have been doing a lot of reading already, but ....

I used Google search term 'EAS valve block overhaul rover' and got some promising looking results.

This was first on the list.


Link to comment
Share on other sites

Hi - not been on here for years, but been checking editing bookmarks, and came across this post, and as I've just bought a P38 after 11 years of Classic LSE (LWB) ownership, and had an EAS problem - now sorted - (it was an intermittantly failing timer delay relay) this intrigued me.

Not sure of the etiquette in recommending one forum on another, if it's not OK then it's up to the mods, but I would think anything that adds to the general fund of knowledge is a good thing.

Anyway, through long experience I've found that by far the most responsive and knowledgeable forum is here:- http://www.landyzone.co.uk/lz/f10/%C2'>

Good luck.


Link to comment
Share on other sites

As this was a Land Rover refurbished unit (valve block and pump) I am reluctant to strip it and break the seal and invalidate any warranty - this has done zero km's as it is on it's bump stops so trying to eliminate any other problems first

if I put power into the valves (Not recommended for a long period) you can hear them click - this does not mean they are opening, but a click all the same, however when all plugged together with ECU, Driver pack etc in place - there is no clicking at all - the wires check out so I will have a look Monday and see if there is an output from the ECU to the driver block - if there is, the must be bad driver block, if no power then it has to be the ECU

to check the output of the driver pack is tricky as it is on a pulse wave and requires an oscilloscope to check the signal - so maybe the ECU is not putting out enough voltage to the Driver pack in order to generate the 24 KHz 12 volt signal required

It would have been nice to put known working parts on this truck as even new parts have been known to be dead on arrival

Link to comment
Share on other sites

Thanks for that Alastair - will give it a looking at

As for the delay timer - I read somewhere this can be removed - problem is I have read so many pages I forgot where it was!

But this timer is one of the things I may have misunderstood - I read it can be the cause of flat batteries as it can switch on the pump with the ignition off

Will check out the forum

Link to comment
Share on other sites

You can operate the valves perfectly safely by putting 12v across the connectors - that's all the ECU does. If you're putting a voltage across the connectors and it's not opening the valves then there's a problem that doesn't involved the ECU (that doesn't rule out additional problems with the ECU, but you should be able to operate the rest of the system by putting jumpers across the connector terminals - it's actually a pretty simple system).

If the valves aren't opening when you jumper the connectors (double check you're using the correct ones, obviously), then I'd start by checking you're actually getting voltage at the valve block connectors (eliminate a wiring issue, especially as it sounds like this loom has been poked around with a fair bit). If you're getting 12v there, then check the valves by putting 12v across the connections there - as it's a sealed unit under warranty I'd be leaning towards exchanging it if it fails that test rather than opening it up to investigate.

Leave the ECU out of the picture until you've got everything else working, as that is a bit of a "black box" from a DIY/regular garage point of view.

Link to comment
Share on other sites

Looks to me like bad connections - I am going to rewire the multi plug that comes from the main harness to the driver pack - there are pin holes all over and looks like the salt air has got in - dull red copper and looking sad.

As I cannot find a good used pigtail here looks like I will order the pins from Polevolt and make my own, and put about a foot of new wire in there as even further up some of the wires there are pin holes from testers

Something is real odd as this morning I faked the pressure switch by removing it from the plug and fitting a manual switch in its place - the system must have been charging the tank for as soon as I flicked the switch the back end shot up - but only the right hand side! this was real odd as it went way too high and looked like the air bag was going to burst (well at least no leaks!)

the pump does not switch off, and the contact of the pressure switch do close but I do not know at what pressure

Link to comment
Share on other sites

The other issue is why there are so many pinholes in the wiring - there must have been some other problem at some time if the wiring has been checked so many times (?); It might at leats be helpful to already have pin holes for you to test, but it does point back at the idea that in the past the ECU was not supplying the necessary signals to the driver ?

Link to comment
Share on other sites

Further to post #13, this diagram from the EAS SID explains it all much better !

If you have the neans to monitor it you can see the signals from ECU to Driver and Driver to Coils of course.

- Typically the signal to the driver (top trace) is also quite brief; The longest one I could see when doing this was only about 1/2 a second (ie. as expected based on listening to the usual click/clack of the solenoids ?)


Link to comment
Share on other sites

I have recently discovered that there are two ecus on the air suspension. There is the one under the drivers seat and there is one to control the valve block and is located in the vavle block box with the compressor and the valve block. If that is any help.

Link to comment
Share on other sites

Fair point Simon-CSK: What we wouild 'normally' describe as the EAS ECU is the one with 'the smarts' under the seat;

The other unit in thne EAS box -the 'Driver' for the Valve Solenoids/Coils- just switches the 3A 'operate' to 1A 'hold' current as described above...

It's all a bit of a moot point though, ie. when does such a module have enough 'smarts' to be called a 'proper' ECU ?

= In theory for example just a control relay in a box could certainly be called an Electronic Control Unit !

Link to comment
Share on other sites

  • 1 month later...

Hi Mike

check the 2 white plug connectors in each foot well they get green corrosion and stop coms to the EAS, ive just cut them out and soldered & heatshrinked - do one at a time as wire colors replicated in the plug and some bays have double wires

also look for corroded shunt from delay timer to wire to pin #1 eas ecu its under the carpet in a high traffic area the plastic wrap falls off putting a blob of soldered wires to bare floor

if you have a hard eas fault then its probably only autologic or testbook that will clear - you can buy from RSW eas unlock and do with a laptop its code based but easy

Im going through the same situation on my own p38 after doing above im leaning towards the driver module - as I just rebuilt the valve block with new o rings from rover rennovations

by all means PM me

Link to comment
Share on other sites

  • 3 weeks later...

hi,had tis problem with my p38 dt 97, had it for weeks no matter what I tried just wouldn't lift, bought eas kit with cd tells you what pressure to inflate on each corner through the laptop it also told me to depressurize the reservoir tank under rear passenger side seat through the laptop followed instructions and eh presto shot up straight away,you must empty the reservoir tank through the computer laptop must have a serial port, dd

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We use cookies to ensure you get the best experience. By using our website you agree to our Cookie Policy